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Performance counters for BizTalk isolated host are not shown

Symptom:

You cannot see any BizTalk Performance counters for a specific BizTalk Isolated Host

Possible cause:

1. BizTalk Performance counters are just shown for Active Biztalk Process:

• [In-process] BizTalk services running
• [Isolated] Hosting process running with BizTalk information loaded, so that it is linked with Biztalk receive locations.

Note: If you are using any BizTalk Web Services (.svc or wsdl), Hosting process is running within IIS worker Process (App Pools).

If your isolated BizTalk Host is not shown in Performance Counters, that would means that Hosting Process is not linked with your Biztalk receive locations:

1. There has not been any call to any of the BizTalk Web Services linked with this BizTalk Host (SOAP/WCF receive location).
2. IIS worker process has been unloaded after inactivity period, by default it is after 20 minutes.

In order to be able to see BizTalk Performance Counters for you BizTalk Isolated Host, you need to make sure that Hosting process is running with BizTalk information loaded, so that it is linked with Biztalk receive locations. To confirm this is the reason why you cannot see the performance counter in your enviornment, please try one of the following actions :

1. Send a message through any of the Receive Location linked with this Isolated Host.
2. Open an Internet Explorer, and browse to any of the URL defined as Receive Location linked with this Isolated Host.

Hope you find it interesting!!