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Comprobación de errores 0x7E: SYSTEM_THREAD_EXCEPTION_NOT_HANDLED

La comprobación de errores SYSTEM_THREAD_EXCEPTION_NOT_HANDLED tiene un valor de 0x0000007E. Esta comprobación de errores indica que un subproceso del sistema generó una excepción que el controlador de errores no ha detectado.

Importante

Este artículo va dirigido a programadores. Si es un cliente que ha recibido un código de error de pantalla azul mientras usa el equipo, consulte Solución de errores de pantalla azul.

Parámetros de SYSTEM_THREAD_EXCEPTION_NOT_HANDLED

Parámetro Descripción
1 Código de excepción que no se gestionó.
2 Dirección en la que se produjo la excepción.
3 Dirección del registro de la excepción.
4 Dirección del registro de contexto.

Causa

Esta comprobación de errores indica que un subproceso del sistema generó una excepción que el controlador de errores no ha detectado. Para interpretarlo, debe identificar qué excepción se generó.

Entre los códigos de excepción comunes se incluyen los siguientes:

  • 0x80000002: STATUS_DATATYPE_MISALIGNMENT indica que se encontró una referencia de datos no alineada.

  • 0x80000003: STATUS_BREAKPOINT indica que se encontró un punto de interrupción o ASSERT cuando no había ningún depurador de kernel conectado al sistema.

  • 0xC0000005: STATUS_ACCESS_VIOLATION indica que se ha producido una infracción de acceso a la memoria.

Para obtener una lista completa de códigos de excepción, consulte Valores de NTSTATUS. Los códigos de excepción se definen en ntstatus.h, un archivo de encabezado que se encuentra en el Kit para controladores de Windows. Para obtener más información, consulte Archivos de encabezado en el Kit para controladores de Windows.

Solución

Si tiene previsto depurar este problema, la dirección de excepción (parámetro 2) debe identificar el controlador o la función que provocó este problema.

Si un controlador aparece por nombre en el mensaje de comprobación de errores, deshabilite o quite ese controlador. Si el problema se limita a un único controlador, establezca puntos de interrupción y avance un solo paso en el código para localizar el error y obtener información sobre los eventos que conducen al bloqueo.

La extensión del depurador !analyze indica información sobre la comprobación de errores y puede resultar útil para determinar la causa raíz.

Se pueden realizar más análisis mediante la extensión !thread y los comandos dds, dps y dqs (mostrar palabras y símbolos). Esta técnica es razonable cuando WinDbg informa "Probablemente causado por: ntkrnlmp.exe".

Si se produce el código de excepción 0x80000003, significa que se alcanzó un punto de interrupción o aserción con codificación fija, pero el sistema se inició con el modificador /NODEBUG. Este problema no debería ocurrir con frecuencia. Si se produce repetidamente, asegúrese de que un depurador de kernel esté conectado y de que el sistema se inicia con el modificador /DEBUG.

Si se produce el código de excepción 0x80000002, el marco de captura proporciona información adicional.

Para obtener más información sobre WinDbg y !analyze, consulte:

Comentarios

Si no está equipado para usar el depurador de Windows para trabajar con este problema, puede usar algunas técnicas básicas de solución de problemas:

  • Consulte el registro del sistema en el Visor de eventos para ver más mensajes de error que puedan ayudarle a identificar el dispositivo o controlador que provoca la comprobaciones de errores 0x7E.

  • Si se identifica un controlador en el mensaje de verificación de errores, deshabilítelo o consulte al fabricante para obtener actualizaciones del controlador.

  • Póngase en contacto con un proveedor de hardware para obtener actualizaciones de ACPI o de otro firmware. Los problemas de hardware, como las incompatibilidades del sistema, los conflictos de memoria y los conflictos de IRQ también pueden generar este error.

  • Deshabilite el almacenamiento en caché de memoria o sombreado del BIOS para intentar resolver el error. También puede ejecutar los diagnósticos de hardware que proporciona el fabricante del sistema.

  • Confirme que todo el hardware nuevo que se instale sea compatible con la versión instalada de Windows. Por ejemplo, puede obtener información sobre el hardware necesario en Cómo buscar las especificaciones del equipo y los requisitos del sistema para Windows 10.

Para obtener más información sobre la solución de problemas generales, consulte Análisis de los datos de la comprobación de errores de la pantalla azul.