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Los volúmenes de disco tardan más tiempo en conectarse cuando se usa el servicio de instantáneas de volumen en equipos que ejecutan muchas operaciones de E/S.

En este artículo se describe una solución alternativa para un problema en el que los volúmenes de disco tardan más tiempo en conectarse después de habilitar el servicio de instantáneas de volumen en los volúmenes.

Número de KB original: 945058

Importante

Este artículo contiene información sobre cómo modificar el Registro. Asegúrese de hacer una copia de seguridad del Registro antes de modificarlo. Asegúrese de saber cómo recuperar el registro en caso de producirse algún problema. Para obtener más información sobre cómo realizar copias de seguridad, restaurar y modificar el registro, haga clic en el número de artículo siguiente para ver el artículo en Microsoft Knowledge Base:
322756 Hacer una copia de seguridad del Registro y restaurarlo en Windows

Síntomas

Al usar el servicio de instantáneas de volumen en equipos basados en Windows Server que ejecutan muchas operaciones de E/S y que tienen muchos datos, experimenta los siguientes síntomas:

  • El tiempo de conmutación por error del clúster es mayor para los grupos de clústeres que contienen recursos de disco para los que ha habilitado el servicio de instantáneas de volumen. Además, los volúmenes de disco de los nodos del clúster tardan más tiempo en conectarse y sin conexión durante una conmutación por error de clúster. Desconectar un disco y después en línea en el mismo nodo también tiene el mismo retraso.

  • Los servidores que no son de clúster tardan más tiempo en iniciarse. Al deshabilitar el servicio de instantáneas de volumen en los volúmenes de servidor, los servidores se inician según lo previsto.

Causa

Este problema se produce debido a la forma en que el controlador de instantáneas de volumen (Volsnap.sys) administra los archivos de instantáneas. Si se crean muchos archivos de instantáneas en los volúmenes de disco, el controlador de instantáneas de volumen tarda más tiempo en procesar esos archivos de instantáneas cuando el sistema pone los volúmenes de disco en línea.

Solución alternativa

Advertencia

Es posible que se produzcan problemas graves si modifica el Registro de forma incorrecta mediante el Editor del Registro u otro método. Estos problemas pueden requerir la reinstalación del sistema operativo. Microsoft no puede garantizar la solución de estos problemas. La modificación del Registro se hará bajo su propia responsabilidad.

Para solucionar este problema, cree una nueva clave del Registro para restringir el número de archivos de instantáneas que se crean en cada volumen de disco a 20.

Nota:

Este valor es solo un valor inicial sugerido. Se recomienda encontrar un valor adecuado para su entorno de trabajo.

Para crear la nueva clave del Registro, siga estos pasos:

  1. Haga clic en Inicio y en Ejecutar, escriba regedit y pulse INTRO.
  2. Busque y haga clic con el botón secundario en la siguiente subclave del Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VSS\Settings
  3. Seleccione Nuevo y, a continuación, haga clic en Valor DWORD.
  4. Escriba MaxShadowCopies y presione ENTRAR.
  5. Haga doble clic en MaxShadowCopies, escriba 20 en el cuadro Datos de valor y, a continuación, haga clic en Aceptar.
  6. Salga del Editor del Registro.
  7. Reinicie el equipo.