Los servidores de administración y sus dispositivos administrados aparecen en gris en la consola de Operations Manager
En este artículo se corrige un problema en el que algunos roles de Operations Manager están atenuados en la consola del operador y el evento 623 se registra en los equipos afectados.
Versión original del producto: Microsoft System Center 2012 Operations Manager
Número de KB original: 975057
Síntomas
En un entorno de Microsoft System Center Operations Manager, uno o varios servidores de administración que hospedan los siguientes roles, junto con los dispositivos administrados de esos servidores de administración, pueden aparecer atenuados o atenuados en la consola del operador:
- Servidor de administración
- Servidor de puerta de enlace
- Agente
Además, se registra un evento similar al siguiente en el registro de Operations Manager en estos equipos:
Origen del evento: ESE
Categoría de evento: Administrador de transacciones
Identificador de evento: 623
Descripción: HealthService (<PID>) El almacén de versiones para la instancia de instancia>< ("<name>") ha alcanzado su tamaño máximo de <valor> Mb. Es probable que una transacción de larga duración impida la limpieza del almacén de versiones y la causa de que se compile en tamaño. Las actualizaciones se rechazarán hasta que la transacción de ejecución prolongada se haya confirmado o revertido por completo. Posible transacción de larga duración:
SessionId: <value>
Contexto de sesión: <valor>
ThreadId de contexto de sesión: <valor>.
Limpieza: <valor>
Nota:
Este evento puede notificar el problema con otros procesos de Operations Manager, en función del rol afectado.
Causa
Este problema suele producirse en un entorno de Operations Manager grande en el que un servidor de administración o un equipo agente administra muchos flujos de trabajo. Esta situación puede producirse por uno de los siguientes motivos:
- Se instalan muchos módulos de administración.
- Un servidor de administración o un agente actúa como proxy para muchos dispositivos.
Operations Manager Servicio de mantenimiento almacena registros de transacciones que no están terminadas en algo denominado almacén de versiones. El almacén de versiones permite al motor de almacenamiento extensible (ESE) realizar un seguimiento y administrar las transacciones actuales. El almacén de versiones tiene una lista de operaciones que realizan las transacciones activas que mantiene el servicio HealthService. Esta lista es una lista en memoria de las modificaciones realizadas en la base de datos del almacén HealthService. Hay un tamaño predeterminado optimizado para una instalación típica de cada rol de Operations Manager. Sin embargo, el tamaño predeterminado puede ser insuficiente para determinados entornos de Operations Manager.
Solución
Importante
Esta sección, método o tarea contiene pasos que le indican cómo modificar el Registro. No obstante, pueden producirse problemas graves si modifica el registro de manera incorrecta. Por lo tanto, asegúrese de que sigue estos pasos con atención. Para la protección añadida, realice una copia de seguridad del Registro antes de modificarlo. A continuación, puede restaurar el Registro si se produce un problema. Para obtener más información sobre cómo realizar copias de seguridad y restaurar el registro, vea Cómo hacer copia de seguridad y restaurar el registro en Windows.
Para resolver el problema, aplique la siguiente configuración del Registro en los equipos que hospedan los roles afectados:
- Subclave:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HealthService\Parameters
- Tipo: REG_DWORD
- Nombre: número máximo de almacén de versiones de persistencia
- Valor: número de páginas de 16 kilobytes
- Base: Decimal
El tamaño predeterminado del almacén de versiones depende del rol de Operations Manager y se define como el número de páginas de 16 kilobytes que se van a asignar en memoria. Los valores predeterminados son los siguientes:
- Agente (sistemas operativos de estación de trabajo): 640 (10 megabytes)
- Agente (sistemas operativos de servidor): 1920 (30 megabytes)
- Servidor de administración: 5120 (80 megabytes)
Si experimenta este problema, se recomienda establecer el tamaño del almacén de versiones para duplicar su tamaño predeterminado. Por ejemplo, si establece el tamaño del almacén de versiones en un equipo que hospeda un rol de servidor de administración, establezca el valor del Registro en 10240 (decimal).
Después de aplicar el cambio del Registro, reinicie el servicio HealthService.
Nota:
- Un tamaño de almacén de versiones mayor requiere que se asigne memoria adicional.
- Si HealthService ejecuta muchos flujos de trabajo, este valor del Registro debe establecerse incluso mayor que el tamaño recomendado.
- Para ver otros problemas en los que algunos de estos síntomas son similares, consulte Solución de problemas de estados de agente gris en System Center Operations Manager.