Compartir a través de


Es posible que se produzca un error de conexión 10054 después de la actualización de SQL Server.

Después de una actualización de Microsoft SQL Server, se produce un error de conexión. Es probable que el error continúe incluso después de usar la cuenta del sistema local para el servicio Agente SQL Server.

Síntomas

Después de actualizar Microsoft SQL Server Standard Edition (STD), Agente SQL Server se inicia y se detiene inmediatamente. Además, recibirá uno o varios de los siguientes mensajes de error:

SQL Server no acepta la conexión (error: 10054). Esperando a que SQL Server permita conexiones. Se intentó la operación: compruebe la conexión en inicio.

Error de SQLServer: 10054, proveedor SSL: el host remoto cerró forzadamente una conexión existente. [SQLSTATE 08001]

Error de SQLServer: 10054, el cliente no puede establecer la conexión [SQLSTATE 08001]

Causa

A veces después de una actualización de Microsoft SQL Server, TLS está deshabilitado y puede experimentar un error de conexión. Compruebe si el protocolo TLS está deshabilitado después de instalar la actualización.

Solución

Para solucionar el error, siga estos pasos:

  1. Habilite TLS estableciendo las siguientes entradas del Registro:

    Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS1.0

    Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS1.1

    Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS1.2

  2. Reinicie el equipo para asegurarse de que se aplica el cambio.

Consulte también

El host remoto cerró forzadamente una conexión existente (error del sistema operativo 10054)