Compartir a través de


Errores de bloqueo de elementos emergentes o cookies de terceros al acceder a experiencias insertadas de Power Automate

Este artículo ayuda a corregir problemas de configuración comunes que impiden que Power Automate se inicie en experiencias insertadas dentro de otras aplicaciones o sitios web.

Síntomas

Al acceder a instancias insertadas de Power Automate, como en SharePoint, Power Apps o a través de integraciones de SDK personalizadas, puede recibir una pantalla en blanco o tener una pantalla que permanezca en el spinner.

Causa

Estos problemas se producen porque las cookies de terceros están bloqueadas en el explorador web.

Solución

Power Automate almacena algunos datos, como la identidad de usuario y las preferencias localmente, mediante las funcionalidades del explorador. Se producen problemas si el explorador bloquea el almacenamiento de dichos datos locales o cookies de terceros establecidos por Power Automate.

Para resolver los problemas, vaya a la configuración del explorador que usa, habilite las cookies de terceros y asegúrese de que los sitios relacionados no estén bloqueados para las cookies.

Instrucciones para Microsoft Edge

  • Opción 1: Habilitar el almacenamiento de cookies de terceros y datos locales para todos los sitios

    1. Seleccione Configuración Cookies>y permisos de sitio.
    2. Expanda Administrar y eliminar cookies y datos del sitio.
    3. Asegúrese de que la configuración Bloquear cookies de terceros está deshabilitada.
    4. Si está presente, quite los siguientes sitios de la configuración de cookies específica del sitio en Bloquear y borrar al salir:
      • https://make.powerautomate.com
      • https://*.make.powerautomate.com
      • https://make.*.powerautomate.com
      • https://login.microsoftonline.com
  • Opción 2: Crear excepciones para permitir el almacenamiento de cookies de terceros y datos locales para Power Automate y servicios asociados

    Nota:

    Los pasos siguientes requieren que la versión del explorador Edge sea 87 o superior.

    1. Seleccione Configuración Cookies>y permisos de sitio.
    2. Expanda Administrar y eliminar cookies y datos del sitio.
    3. Seleccione Agregar en Permitir y agregar:
      • [*.]powerautomate.com
    4. Seleccione Borrar datos de exploración al cerrar.
    5. Asegúrese de que las cookies y otros datos del sitio están deshabilitados. Si quiere mantenerla habilitada, seleccione Agregar en su lugar y, a continuación, agregue:
      • [*.]powerautomate.com

Instrucciones para Google Chrome

  • Opción 1: Habilitar el almacenamiento de cookies de terceros y datos locales para todos los sitios

    1. Seleccione Configuración Privacidad>y seguridad.
    2. Expanda Cookies y otros datos del sitio.
    3. Asegúrese de que Bloquear cookies de terceros o Bloquear todas las cookies no está seleccionada.
    4. Si está presente, quite los siguientes sitios de la configuración de cookies específica del sitio en Sitios que siempre pueden usar cookies y Siempre borrar cookies cuando se cierran las ventanas:
      • https://make.powerautomate.com
      • https://*.make.powerautomate.com
      • https://make.*.powerautomate.com
      • https://login.microsoftonline.com
  • Opción 2: Crear excepciones para permitir el almacenamiento de cookies de terceros y datos locales para Power Automate y servicios asociados

    1. Seleccione Configuración Privacidad>y seguridad.
    2. Expanda Cookies y otros datos del sitio.
    3. Vaya a Sitios que siempre pueden usar cookies, seleccione Agregar y, a continuación, agregue:
      • [*.]powerautomate.com
    4. Asegúrese de seleccionar la opción Incluir cookies de terceros en este sitio al agregar el sitio.