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Resolución de códigos de error de creación de sesión para una ejecución de flujo de escritorio desatendido

En este artículo se proporcionan soluciones en segundo plano y posibles a los SessionCreationError códigos de error y SessionCreationErrorWithThirdPartyCredentialProvider que pueden producirse durante una ejecución de flujo de escritorio desatendido en Microsoft Power Automate.

Se aplica a: Power Automate

Síntomas

Es posible que se produzca un error en la ejecución del flujo de escritorio desatendido con el SessionCreationError código de error o SessionCreationErrorWithThirdPartyCredentialProvider .

Causa

Cuando se ejecuta una sesión desatendida, Power Automate intenta crear una sesión de Escritorio remoto (RDP) en la máquina de destino. Si se produce un error en la creación de esta sesión, es posible que reciba uno de los siguientes códigos de error:

SessionCreationErrorWithThirdPartyCredentialProvider

Este código de error se produce porque el software de terceros interfiere con la capacidad de Power Automate de crear una sesión en la máquina. Power Automate no admite algunos proveedores de credenciales de terceros.

Solución

Para resolver el problema, póngase en contacto con el administrador para desinstalar el proveedor de credenciales que Power Automate no admite.

Puede encontrar la lista completa de proveedores de credenciales (muchos de los cuales están integrados) en la máquina en la siguiente clave del Registro:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\Credential Providers

Cada subclave representa un proveedor de credenciales instalado. En la tabla siguiente se enumeran los proveedores de credenciales que Power Automate actualmente no admite. Si tiene la siguiente clave del Registro, trabaje con el administrador del sistema para desinstalar el software correspondiente.

Nombre Nombre de subclave
Restablecimiento de contraseña de escritorio de SailPoint Technologies 0094A34B-0BF0-4789-8B2D-8339E469D756

SessionCreationError

Este código de error se produce cuando se produce un error en la creación de una sesión por un motivo desconocido.

Solución

Para resolver el problema:

  • Asegúrese de que puede realizar escritorio remoto en la máquina desde otra máquina de la red. Si usa Windows Server, puede intentar el escritorio remoto en "localhost" desde el propio equipo local cuando haya iniciado sesión como otra cuenta. Si se produce un error en estas acciones, consulte Solución de problemas de conexión de Escritorio remoto general.
  • Si tiene un aviso legal habilitado para el inicio de sesión, trabaje con el administrador del sistema para intentar deshabilitarlo. Para ver si se activa el aviso legal, abra el Editor del Registro y vaya a Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System. Si legalnoticecaption o legalnoticetext no está vacío, trabaje con el administrador del sistema para deshabilitar el aviso legal.
  • Asegúrese de que no haya instalado ningún software de terceros que pueda afectar al inicio de sesión o interferir con la creación de una conexión de Escritorio remoto.

Aviso de declinación de responsabilidades sobre la información de terceros

Los productos de otros fabricantes que se mencionan en este artículo han sido creados por compañías independientes de Microsoft. Microsoft no ofrece ninguna garantía, ya sea implícita o de otro tipo, sobre la confiabilidad o el rendimiento de dichos productos.