Solución de errores de cola de ejecución de flujo de escritorio
En este artículo se proporcionan soluciones en segundo plano y posibles a errores basados en cola detectados durante las ejecuciones de flujo de escritorio.
Se aplica a: Power Automate
Número de KB original: 5004537
Síntomas
Es posible que el flujo de escritorio no se ejecute con el código NoCandidateMachine
de error o los detalles del error "No se encontró ninguna máquina capaz de ejecutar el flujo de escritorio".
También puede recibir uno de estos códigos de suberror comunes:
- SessionExistsForTheUserWhenUnattended
- UnattendedUserSessionDisconnected
- UnattendedUserSessionLocked
- AttendedUserSessionNotActive
- AttendedUserNotLoggedIn
- UIFlowAlreadyRunning
Causa
Cuando no hay ninguna máquina disponible, Power Automate crea una cola para contener los flujos de escritorio a la espera de ejecutarse. Una vez disponible una máquina, se seleccionará la siguiente ejecución de flujo de escritorio para que se ejecute en función de la prioridad y el tiempo de solicitud. Si no hay ninguna máquina disponible después de seis horas desde el momento en que se solicitó, el flujo de escritorio agotará el tiempo de espera y generará un error con un NoCandidateMachine
código de error.
Como se mencionó en el mensaje de error, este error significa que el orquestador no puede encontrar una máquina disponible para ejecutar el flujo de escritorio. Este error se produce antes de que se inicie la ejecución del flujo de escritorio.
Importante
Power Automate escala automáticamente el número de ejecuciones de flujo de escritorio simultáneas al valor máximo admitido. La cola de ejecución de la máquina sigue un enfoque de primera entrada y salida, lo que significa que la primera ejecución recibida es la siguiente que se va a ejecutar. Si todas las máquinas disponibles han alcanzado sus sesiones simultáneas máximas y no pueden ejecutar la siguiente ejecución en la cola, la cola se bloquea hasta que una máquina esté disponible para ejecutar la siguiente ejecución en la cola.
SessionExistsForTheUserWhenUnattended
Este error se produce cuando intenta ejecutar un flujo de escritorio desatendido en una máquina de destino en la que el usuario usado en la conexión de flujo de escritorio ha iniciado sesión.
Solución
Para resolver el problema, cierre la sesión (una sesión bloqueada provocará este error) y confirme que no ha iniciado sesión con el mismo usuario en el equipo.
UnattendedUserSessionDisconnected
Este error se produce cuando intenta ejecutar un flujo de escritorio desatendido en una máquina de destino en la que hay una sesión desconectada para el usuario que se usa en la conexión de flujo de escritorio.
Solución
Para resolver el problema, cierre la sesión desconectada y confirme que no ha iniciado sesión con el mismo usuario en el equipo.
UnattendedUserSessionLocked
Este error se produce cuando se intenta ejecutar un flujo de escritorio desatendido en una máquina de destino en la que hay una sesión bloqueada para el usuario que se usa en la conexión de flujo de escritorio.
Solución
Para resolver el problema, cierre la sesión bloqueada y confirme que no ha iniciado sesión con el mismo usuario en el equipo.
AttendedUserSessionNotActive
Este error se produce al intentar ejecutar un flujo de escritorio asistido en un equipo de destino en el que la sesión del usuario está bloqueada o desconectada. Los flujos de escritorio asistidos solo se pueden ejecutar si la máquina está desbloqueada en una sesión en la que el usuario actual coincide con el del flujo de escritorio.
Solución
Para resolver el problema,
- Vuelva a conectarse en la máquina con el usuario usado para la ejecución con asistencia y deje que la sesión está activa en la máquina.
- Compruebe que tiene como destino la máquina correcta. Para ello, abra la aplicación en tiempo de ejecución de la máquina y seleccione Ver máquina en el portal para comprobar que le lleva a la máquina que tiene como destino en la ejecución.
AttendedUserNotLoggedIn
Este error se produce cuando el usuario especificado en la conexión no ha iniciado sesión en la máquina de destino.
Solución
Para resolver el problema,
- Conéctese en el equipo con el usuario usado para la ejecución con asistencia y deje que la sesión está activa en la máquina.
- Compruebe que tiene como destino la máquina correcta. Para ello, abra la aplicación en tiempo de ejecución de la máquina y seleccione Ver máquina en el portal para comprobar que le lleva a la máquina que tiene como destino en la ejecución.
- Compruebe las credenciales usadas en la conexión y asegúrese de que son las que se usan en la sesión desbloqueada. Puede comprobar su identidad escribiendo
whoami
cualquier símbolo del sistema.
Nota:
Para AttendedUserSessionNotActive
los errores o AttendedUserNotLoggedIn
, compruebe que la cuenta que ejecuta el servicio Power Automate (UIFlowService) tiene permisos de Escritorio remoto en la máquina. De forma predeterminada, el servicio Power Automate se ejecuta como NT SERVICE\UIFlowService
. Si no lo ha cambiado, compruebe que NT SERVICE\UIFlowService
está en el grupo Usuarios de Escritorio remoto. Para ello, vaya a Iniciar>ejecución, escriba usrmgr.msc, seleccione Grupos, haga doble clic en el grupo Usuarios de Escritorio remoto y compruebe que se incluye la cuenta. Si no está incluido, inclúyelo (esto requiere permisos de administrador) y reinicie la máquina.
UIFlowAlreadyRunning
Cuando un flujo de escritorio ya se está ejecutando en la máquina, este error puede producirse en una de las situaciones siguientes:
- Ejecuta un flujo de escritorio desatendido o asistido y el número de sesiones activas en la máquina ha alcanzado su límite.
- Intenta abrir una sesión para un usuario que ya ha iniciado sesión.
Solución
Para resolver el problema, espere a que los flujos que ya se estén ejecutando se completen o cancelen la ejecución de su flujo de nube primario.
Otros códigos de error
Para obtener información sobre otros códigos de error que pueden producirse al ejecutar flujos de escritorio y pasos para mitigarlos, consulte Código de error al ejecutar un flujo de escritorio desatendido o asistido.
Más información
Si no se proporciona el código de suberror, compruebe si:
La máquina o todas las máquinas del grupo de máquinas están sin conexión.
Inicie la máquina y asegúrese de que Power Automate Desktop está correctamente instalado y puede comunicarse con Internet.
El grupo de máquinas está vacío.
Asegúrese de que el grupo de máquinas contiene al menos una máquina antes de asignarle una ejecución de flujo de escritorio.
La máquina o todas las máquinas del grupo de máquinas están ocupadas continuamente.
Si las máquinas no recogen el flujo de escritorio en el tiempo, es probable que los recursos de la máquina asignados no se escalen lo suficiente para satisfacer la demanda de flujo de trabajo. Agregar más máquinas podría ayudar a distribuir la carga de trabajo.
No se puede acceder a la máquina debido a problemas de red (incluido el proxy o el firewall).
Trabaje con el administrador de TI para asegurarse de que las máquinas son accesibles.
El problema es transitorio.
Intente cambiar la directiva de reintento en la configuración de las acciones.
La máquina o todas las máquinas del grupo de máquinas no pueden conectarse con el flujo de escritorio.
Asegúrese de que se cumple una de las siguientes opciones:
- No está intentando ejecutar un flujo desatendido en un grupo en el que todas las máquinas han iniciado sesión.
- No está intentando ejecutar un flujo de asistencia en un grupo en el que todas las máquinas están firmadas.
La máquina ya no se puede usar.
Agregue una nueva máquina y actualice las conexiones de flujo de escritorio en los flujos de nube para usar la nueva máquina.
Si tiene una copia de seguridad de los flujos de escritorio en la cola de ejecución debido a uno de los motivos anteriores, puede cancelar de forma masiva las ejecuciones de flujo de escritorio cancelando la ejecución del flujo de nube primario mediante la acción Cancelar ejecución del flujo primario en la página Ejecuciones de flujo de escritorio. Una vez resuelto el problema de la máquina, puede reiniciar esos flujos en la nube.