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MaxRDSessionDurationReached o SessionHasLoggedOffWithMaxIdleTime se produce durante una ejecución de flujo de escritorio

En este artículo se proporciona una resolución de códigos de error que se producen durante una ejecución de flujo de escritorio en un entorno de nube en Microsoft Power Automate.

Síntomas

Al ejecutar un flujo de escritorio en un entorno de nube en Power Automate, es posible que se produzca un error en la ejecución del flujo con uno de los códigos de error que indica el nombre del valor del Registro y su ruta de acceso del Registro específica.

{ 
    "error":{
        "code": "MaxRDSessionDurationReached",
        "message": "The session 5 duration (1856000 milliseconds) exceeded the one set in registry for MaxConnectionTime with value 1200000 in registry path Software\Policies\Microsoft\Windows NT\Terminal Service."
    } 
}
{ 
    "error":{
        "code": "SessionHasLoggedOffWithMaxIdleTime",
        "message": "The session 5 duration (1856000 milliseconds) exceeded the one set in registry for MaxIdleTime with value 1200000 in registry path Software\Policies\Microsoft\Windows NT\Terminal Service."
    } 
}

Causa

El mensaje de error indica que la sesión de Escritorio remoto se ha cerrado porque superó el límite de tiempo especificado en el registro (MaxConnectionTime o MaxIdleTime). Este problema se produce cuando el límite de tiempo de sesión en la configuración del Registro es menor que el tiempo necesario para completar el flujo de escritorio.

Solución

Para solucionar este problema, póngase en contacto con el administrador para cambiar la configuración mediante una de las opciones.

Opción 1: Mediante el Editor de directivas de grupo local

Compruebe la configuración de directiva de grupo para asegurarse de que no hay ninguna configuración establecida para cerrar la sesión de Escritorio remoto debido a los límites de tiempo. Para ello, abra el Editor de directivas de grupo local y vaya a Configuración>del equipo Plantillas administrativas Componentes>de Windows Límites>de tiempo de sesión de>Servicios de Escritorio remoto.

  • Si el mensaje de error apunta al valor del registro MaxConnectionTime , compruebe la opción Establecer límite de tiempo para las sesiones activas de Servicios de Escritorio remoto. Si está habilitado, deshabilite o establezca el valor de límite de sesión activo en Nunca.
  • Si el mensaje de error apunta al valor del registro MaxIdleTime , compruebe la opción Establecer límite de tiempo para las sesiones de Servicios de Escritorio remoto activas pero inactivas . Si está habilitado, deshabilite o establezca el valor de límite de sesión activo en Nunca.

Opción 2: Mediante el Editor del Registro

Abra el Editor del Registro y busque el nombre del valor del Registro del mensaje de error en la ruta de acceso del Registro especificada en Equipo\HKEY_LOCAL_MACHINE\.

Por ejemplo, Computer\HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows NT\Terminal Service

Si existe el valor del registro MaxConnectionTime o MaxIdleTime , establézcalo en 0 (cero), lo que significa que es ilimitado.

Nota:

El valor del Registro también se puede eliminar o establecer en un valor mayor que el tiempo de ejecución máximo del flujo de escritorio.

Nombre del valor de registro Descripción
MaxConnectionTime Especifica el tiempo máximo (en milisegundos) que una sesión de Escritorio remoto puede permanecer activa, independientemente de la actividad.
MaxIdleTime Especifica el tiempo máximo (en milisegundos) que una sesión de Escritorio remoto puede permanecer inactiva (sin entrada de usuario, como la actividad del teclado o el mouse) antes de que se cierre la sesión.