Compartir a través de


"Actualizar todo" no funciona después de exportar los datos de la aplicación a una hoja de cálculo dinámica

Síntomas

Use el comando Exportar a Excel para exportar los datos de la aplicación a una hoja de cálculo dinámica. A continuación, abra el archivo descargado y actualice los datos seleccionando Actualizar todos los datos>. En esta situación, verá que los datos desaparecen y el libro aparece en blanco. Puede aparecer el siguiente mensaje de error:

Esta consulta web no devolvió datos. Para cambiar la consulta, haga clic en Aceptar, haga clic en la flecha del cuadro nombre de la barra de fórmulas, haga clic en el nombre del intervalo de datos externo para la consulta web, haga clic con el botón derecho en la selección y, a continuación, haga clic en Editar consulta.

Captura de pantalla que muestra que la consulta web no devolvió ningún error de datos que se produce después de actualizar los datos de la aplicación exportados.

Causa

Este problema se produce cuando los datos a los que tiene acceso están protegidos con contraseña y el archivo de Excel no puede enviar contraseñas a orígenes de datos externos.

Solución

Para resolver esta incidencia, deberá editar y guardar la consulta web.

  1. En el archivo de Excel, seleccione Consultas de datos>y conexiones.

    Captura de pantalla que muestra la opción Consultas y conexiones en la pestaña Datos.

  2. Se abrirá el panel Consultas y conexiones a la derecha de la ventana. En la pestaña Conexiones , haga clic con el botón derecho en la consulta y seleccione Propiedades.

    Captura de pantalla que muestra la configuración propiedades de una consulta en el panel Consultas y conexiones.

  3. Se abrirá la ventana Propiedades de conexión. En la pestaña Definición , seleccione Editar consulta.

    Captura de pantalla que muestra el botón Editar consulta en el ventana Propiedades de conexión.

  4. Si se le solicita, escriba el nombre de usuario y la contraseña. Ingrese el mismo usuario y contraseña que usa para iniciar sesión en su aplicación.

  5. En la ventana Editar consulta web, seleccione Ir. Se produce un mensaje de error:

    No se puede completar esta acción

    Captura de pantalla que muestra el botón Ir en la ventana Editar consulta web.

  6. Cierre la ventana Editar consulta web.

  7. De este modo deberá solucionar el problema. Vuelva a actualizar los datos de la hoja de cálculo seleccionando Actualizar todos los datos>.

    Captura de pantalla que muestra cómo actualizar los datos de la aplicación en Excel.

Si los pasos anteriores no resuelven el problema, siga estos pasos adicionales:

  1. Escriba el siguiente vínculo en la barra de direcciones de la ventana Editar consulta web para acceder a la página Configuración avanzada de Microsoft Dynamics 365 Customer Engagement. Recuerde reemplazar por OrgURL la dirección URL de la organización.

    https://OrgURL/main.aspx?settingsonly=true

  2. Cierre sesión con el vínculo de opción de perfil superior derecho y vuelva a iniciar sesión con la identidad correcta.

  3. Una vez que haya iniciado sesión, cierre la ventana Editar consulta web y, después, en el archivo de Excel, seleccione Actualizar todos los datos>. Los datos se actualizarán según lo previsto.

Consulte también

Exportar datos a una hoja de cálculo dinámica de Excel