Compartir a través de


Los registros de Dataverse se crean sin campos obligatorios

Se aplica a: Dynamics 365 Field Service, Dataverse

Síntomas

Después de que los usuarios escriban datos a través de la API web de Microsoft Dataverse, faltan algunos campos obligatorios o no se rellenan en los registros creados. Por ejemplo, el campo Título del caso obligatorio está en blanco en un caso creado, como se muestra en la captura de pantalla siguiente.

Captura de pantalla de un ejemplo sobre los campos obligatorios que faltan.

Al abrir el caso afectado, debe escribir un valor para el campo Título del caso.

Captura de pantalla para especificar un valor para el campo Título del caso.

Causa

Este problema se produce si los registros se crean a partir de una herramienta de terceros, como Postman. Estas herramientas no comprueban los campos necesarios. En su lugar, envían los datos tal como están.

Solución alternativa

Para solucionar este problema, asegúrese de comprobar los siguientes elementos:

  • Compruebe que los campos obligatorios se incluyen en los flujos.
  • Compruebe la existencia de campos obligatorios en las entidades que se crean a través de solicitudes HTTP.