Error 80072f8f al enviar con winhttp en Smsts.log durante la implementación del sistema operativo mediante medios preconfigurados o de arranque
Este artículo le ayuda a corregir un problema en el que el Asistente para secuencia de tareas devuelve el error 80004005 y Smsts.log registra el error Envío con winhttp; error 80072f8f durante una implementación del sistema operativo que usa medios preconfigurables o de arranque.
Versión original del producto: Configuration Manager (rama actual), Microsoft System Center 2012 R2 Configuration Manager, Microsoft System Center 2012 Configuration Manager
Número de KB original: 4551033
Síntomas
Puede crear medios de arranque o medios preconfigurados en Configuration Manager. Cuando se usa el medio para iniciar el equipo de destino, el Asistente para secuencia de tareas se bloquea en la directiva de recuperación de este paso del equipo durante unos 90 segundos y, a continuación, devuelve el siguiente mensaje de error:
No se pudo ejecutar la secuencia de tareas
Error al recuperar la directiva para este equipo (0x80004005). Para obtener más información, póngase en contacto con el administrador del sistema o el operador del departamento de soporte técnico.
Los siguientes mensajes de error se registran en X:\Windows\Temp\SMSTSLog\smsts.log en el equipo cuando el motor de secuencia de tareas intenta ponerse en contacto con el punto de administración para sincronizar la información de hora:
Información de hora actual de TSMBootstrap:
Obtención de información de hora de TSMBootstrap
Identidad de cliente de solicitud de TSMBootstrap
TSMBootstrap Estableciendo el autenticador.
TSMBootstrap CLibSMSMessageWinHttpTransport::Send: WinHttpOpenRequest - URL: <MP>:443 CCM_POST /ccm_system_AltAuth/request
TSMBootstrap SSL, mediante el autenticador en la solicitud.
TSMBootstrap En SSL, pero sin certificado de cliente.
TSMBootstrap [TSMESSAGING] AsyncCallback():
-----------------------------------------------------------------
TSMBootstrap [TSMESSAGING] AsyncCallback(): WINHTTP_CALLBACK_STATUS_SECURE_FAILURE encontrado
TSMBootstrap [TSMESSAGING] : dwStatusInformationLength es 4
TSMBootstrap [TSMESSAGING] : *lpvStatusInformation es 0x8
TSMBootstrap [TSMESSAGING] : WINHTTP_CALLBACK_STATUS_FLAG_INVALID_CA se establece
TSMBootstrap [TSMESSAGING] AsyncCallback():
-----------------------------------------------------------------
Error TSMBootstrap. Se recibió 0x80072f8f de WinHttpSendRequest.
TSMBootstrap Envío con winhttp erróneo; 80072f8f. Reintentando.
TSMBootstrap Reintentar e ignorar los errores de seguridad de fecha.
TSMBootstrap [TSMESSAGING] AsyncCallback():
-----------------------------------------------------------------
TSMBootstrap [TSMESSAGING] AsyncCallback(): WINHTTP_CALLBACK_STATUS_SECURE_FAILURE encontrado
TSMBootstrap [TSMESSAGING] : dwStatusInformationLength es 4
TSMBootstrap [TSMESSAGING] : *lpvStatusInformation es 0x8
TSMBootstrap [TSMESSAGING] : WINHTTP_CALLBACK_STATUS_FLAG_INVALID_CA se establece
TSMBootstrap [TSMESSAGING] AsyncCallback():
-----------------------------------------------------------------
TSMBootstrap hr, HRESULT=80072f8f
TSMBootstrap Envío con winhttp erróneo; 80072f8f
Después del error inicial, el motor de secuencia de tareas intenta cuatro veces más ponerse en contacto con el punto de administración y experimenta una pausa creciente entre cada intento. Sin embargo, todos los intentos producen un error y devuelven los mismos mensajes de error antes de que se devuelvan algunos mensajes de error finales, como se indica a continuación:
Si el medio está configurado como medio dinámico, los siguientes mensajes de error finales se registran en Smsts.log:
TSMBootstrap Send (pReply, nReplySize), HRESULT=80072f8f
TSMBootstrap no pudo enviar la solicitud
TSMBootstrap DoRequest (sReply, true), HRESULT=80072f8f
TSMBootstrap No se pudo obtener la identidad del cliente (80072f8f)
TSMBootstrap ClientIdentity.RequestClientIdentity (), HRESULT=80072f8f
TSMBootstrap no pudo solicitar el cliente
Error de TSMBootstrap SyncTimeWithMP(). 80072f8f.
TSMBootstrap No se pudo obtener información de hora de MP:https://<MP>
.
TSMBootstrap MpCnt > 0, HRESULT=80004005
TSMBootstrap QueryMPLocator: no se reciben ubicaciones de MP válidas.
TSMBootstrap TSMBootstrapUtil::QueryMPLocator ( true, sSMSTSLocationMPs.c_str(), sMediaPfx.c_str(), sMediaGuid.c_str(), sAuthenticator.c_str(), sEnterpriseCert.c_str(), sServerCerts.c_str(), nHttpPort, nHttpsPort, bUseCRL, m_bWinPE, httpS, http, accessibleMpCnt), HRESULT=80004005
TSMBootstrap No se pudo consultar el localizador de puntos de administración
TSMBootstrap Salir de TSMediaWizardControl::GetPolicy.
TSMBootstrap pWelcomePage-m_pTSMediaWizardControl-GetPolicy>>(), HRESULT=80004005
Error del Asistente para configuración de TSMBootstrap: error al recuperar la directiva para este equipo (0x80004005). Para obtener más información, póngase en contacto con el administrador del sistema o el operador del departamento de soporte técnico.Si el medio está configurado como basado en sitio, los siguientes mensajes de error finales se registran en Smsts.log:
TSMBootstrap Send (pReply, nReplySize), HRESULT=80072f8f
TSMBootstrap no pudo enviar la solicitud
TSMBootstrap DoRequest (sReply, true), HRESULT=80072f8f
TSMBootstrap No se pudo obtener la identidad del cliente (80072f8f)
TSMBootstrap ClientIdentity.RequestClientIdentity (), HRESULT=80072f8f
TSMBootstrap no pudo solicitar el cliente
Error de TSMBootstrap SyncTimeWithMP(). 80072f8f.
TSMBootstrap No se pudo obtener información de hora de MP:https://<MP>
.
TSMBootstrap sMP.length() > 0, HRESULT=80004005
TSMBootstrap TSMBootstrapUtil::SelectMP ( sSMSTSMP.c_str(), sMediaPfx.c_str(), sMediaGuid.c_str(), sAuthenticator.c_str(), sEnterpriseCert.c_str(), sServerCerts.c_str(), nHttpPort, nHttpsPort, bUseCRL, m_bWinPE, sSiteCode, sAssignedSiteCode, sMP, sCertificates, sX86UnknownMachineGUID, sX64UnknownMachineGUID), HRESULT=80004005
TSMBootstrap No se pudo seleccionar mp
TSMBootstrap Salir de TSMediaWizardControl::GetPolicy.
TSMBootstrap pWelcomePage-m_pTSMediaWizardControl-GetPolicy>>(), HRESULT=80004005
Error del Asistente para configuración de TSMBootstrap: error al recuperar la directiva para este equipo (0x80004005). Para obtener más información, póngase en contacto con el administrador del sistema o el operador del departamento de soporte técnico.
La siguiente información detallada se aplica al error 80072F8F:
Código de error: 0x80072F8F (2147954575)
Nombre del error: WININET_E_DECODING_FAILED
Origen de error: Windows
Mensaje de error: Error en la descodificación de contenido
Causa
Este problema ocurre si se cumplen las siguientes condiciones:
- Use PKI en el entorno de Configuration Manager.
- Los medios de arranque o los medios preconfigurados se crean en el sitio de administración central.
- Configure los puntos de administración para que usen HTTPS.
Si usa PKI en el entorno de Configuration Manager, la entidad de certificación raíz (CA) se especifica en el sitio primario, pero no en el sitio de administración central. Dado que el sitio de administración central no tiene la información de entidad de certificación raíz, el medio creado no contiene la información de ca raíz. Por lo tanto, las solicitudes que se envían a un punto de administración habilitado para HTTPS producen un error sin la información de ca raíz.
Solución
Para corregir el problema, cree los medios de arranque o los medios preconfigurados en un sitio primario en lugar de en el sitio de administración central.
Más información
Para los medios que se usarán en varios sitios, configure el medio como medio dinámico. Puede crear medios dinámicos en cualquier sitio. No se limita a crearlo en el sitio de administración central.