Compartir a través de


Los clientes de Configuration Manager se vuelven a instalar cada cinco horas y pueden provocar una actualización involuntaria del cliente.

En este artículo se describe un problema en el cliente de System Center 2012 Configuration Manager y el cliente de System Center 2012 R2 Configuration Manager que podrían provocar una actualización involuntaria del cliente en un entorno de rama actual de Configuration Manager o rama de mantenimiento a largo plazo (LTSB).

Versión original del producto: Microsoft System Center 2012 Configuration Manager, Microsoft System Center 2012 R2 Configuration Manager
Número de KB original: 4018655

Resumen

Inicialmente, se produce un error en la instalación del cliente de Configuration Manager (CCMSetup) y hace que se registre una tarea de reintento de cliente en el Programador de tareas de Windows. Una vez que la instalación del cliente se realiza correctamente, la tarea de reintento no se elimina según lo previsto. Por lo tanto, los clientes continúan reinstalar cada cinco horas.

En esta situación, si actualiza la infraestructura de Configuration Manager a la rama actual de Configuration Manager o LTSB, y si no actualiza los clientes de Configuration Manager, la tarea de reintento programada continúa obligando a una reinstalación de cliente cada cinco horas.

La próxima vez que se ejecute CCMSetup, los clientes encuentran un punto de administración actualizado o un punto de distribución y vuelven a instalar el software cliente. Esto actualiza los clientes a Configuration Manager.

Estas actualizaciones continuas se producen fuera del proceso de actualización normal configurado por el administrador. Esto incluye la característica piloto de cliente.

Síntomas

En un entorno de Microsoft System Center 2012 o System Center 2012 R2, observe los siguientes síntomas:

  • Los clientes se vuelven a instalar correctamente cada cinco horas. Esta actividad se registra en ccmsetup.log y registros de eventos de Windows.
  • Al ver la carpeta \Microsoft\Microsoft\ConfigurationManager en el Programador de tareas, encontrará una tarea denominada Tarea de reintento de cliente de Configuration Manager.

Causa

Este problema se produce porque CCMSetup crea la tarea de reintento de cliente en la carpeta incorrecta del cliente. Esto impide que CCMSetup busque y quite la tarea.

La tarea programada se crea en la carpeta \Microsoft\Microsoft\Configuration Manager en lugar de en la carpeta \Microsoft\Configuration Manager.

Solución alternativa 1

Quite manualmente la tarea Reintento de cliente de Configuration Manager de la carpeta \Microsoft\Microsoft\Configuration Manager mediante el Programador de tareas.

Solución alternativa 2

Implemente un script para quitar la tarea de reintento de cliente de Configuration Manager de la carpeta \Microsoft\Microsoft\Configuration Manager.

Comandos de Windows PowerShell de ejemplo para agregar al script:

get-scheduledtask -taskname "Configuration Manager Client Retry Task"  
unregister-scheduledtask -taskname "Configuration Manager Client Retry Task" -confirm:$false

Más información

En la versión 1602 y posteriores de la rama actual de Configuration Manager, y en la versión 1606 de LTSB, Ccmsetup quita correctamente la tarea programada después de actualizar los clientes.