No se encontró el delimitador de confianza para la ruta de certificación al configurar la conexión de la aplicación
Síntomas
Al intentar conectarse a Supply Chain Management, la aplicación Administración de almacenes puede mostrar el siguiente mensaje de error:
java.security.cert.certPathValidatorException: no se encontró el anclaje de confianza para la ruta de certificación.
Este problema puede afectar a los dispositivos con las siguientes propiedades:
- Versión del sistema operativo: Android 4.4.x (como Zebra TC55). Esto no es un problema en las versiones recientes de Android.
- Ubicación de administración de la cadena de suministro: nube
- Modo de conexión: secreto de cliente o certificado
Causa posible
Microsoft puede haber actualizado los certificados SSL de servidor usados por la administración de cadenas de suministro. Como resultado, el certificado raíz o uno de los certificados intermedios pueden haber cambiado, por lo que el nuevo certificado no está en la lista de certificados de sistema de confianza para el dispositivo móvil. Las versiones más recientes de Android actualizan automáticamente las listas de certificados de confianza, pero Android 4.4.x no.
Solución
Para resolver este problema, realice una de las siguientes acciones:
- Use la solución alternativa descrita en la sección siguiente para actualizar cada dispositivo pertinente.
- Puede ponerse en contacto con Zebra o Google para obtener una actualización de los certificados de entidad de certificación (CA) de confianza del sistema. Sin embargo, no hemos confirmado esto.
- Si es posible, considere la posibilidad de reemplazar dispositivos antiguos por dispositivos que ejecutan una versión más reciente de Android (donde los certificados de CA de confianza se actualizan automáticamente).
Solución alternativa
Paso 1: Exportación del nuevo certificado raíz desde la administración de la cadena de suministro
Descargue manualmente el nuevo certificado raíz mediante el explorador de Internet haciendo lo siguiente:
- Inicie sesión en Dynamics Supply Chain Management y abra la página principal.
- En la barra de direcciones del explorador, seleccione el icono de bloqueo para abrir el cuadro de diálogo Ubicación es seguro .
- En el cuadro de diálogo, seleccione Certificado (válido) para abrir la ventana Certificado para ese certificado.
- Abra la pestaña Ruta de acceso de certificación de la ventana Certificado .
- Seleccione el certificado superior que se muestra en la jerarquía. (este es el certificado raíz).
- Abra la pestaña Detalles de la ventana Certificado .
- Seleccione el botón Copiar al archivo en la parte inferior de la pestaña Detalles .
- Se abre el Asistente para exportación de certificados. Seleccione Siguiente para continuar.
- Se abre la página Exportar formato de archivo. Seleccione DER codificado binario X.509 (. CER). A continuación, seleccione Siguiente para continuar.
- Se abre la página Archivos para exportar , especifique un nombre de archivo y una ubicación. A continuación, seleccione Siguiente para continuar.
- Se abre la página Finalización del asistente para exportación de certificados, que muestra el resultado de la exportación. Seleccione Finalizar.
Paso 2: Instalar el certificado descargado en los dispositivos afectados
Instale el certificado descargado haciendo lo siguiente:
- Transfiera el certificado que descargó en el paso anterior al dispositivo que desea actualizar. Por ejemplo, puede usar una tarjeta SD o una conexión de red para que el archivo esté disponible para el dispositivo.
- Abra la configuración de seguridad del dispositivo y elija la opción de menú para instalar un certificado desde un archivo. (Los pasos exactos para esto varían en función de la versión del dispositivo y del sistema operativo).
- El nuevo certificado ahora debe mostrarse en la pestaña Usuario para los certificados de confianza.
- Repita este procedimiento para cada dispositivo afectado.