Compartir a través de


Solucionar problemas con los productos

Siga las instrucciones de este artículo para solucionar los problemas que podría surgir al trabajar con productos en Dynamics 365 Sales.

Problema 1: la reparentación no funciona o el campo Primario no está visible

La reparentación del producto permite cambiar el elemento primario de un registro de producto existente para que los productos secundarios hereden las propiedades de producto adecuadas. Para obtener más información, vea Cambiar el elemento primario de un producto.

Causa

Si no ve el campo Primario en el formulario Producto, podría deberse a que ha personalizado el formulario Principal del producto mediante la solución no administrada. Para obtener más información, consulte Información general de soluciones.

En algunos casos, los formularios de producto no se combinan correctamente y, debido a esto, el campo primario obligatorio no se agrega al formulario.

Solución

Para resolverlo, debe volver a agregar el campo Primario al formulario. Puede hacerlo a través de la personalización o mediante el Asistente para importación y exportación de soluciones. Para obtener más información, consulte Exportación de soluciones e Importación de soluciones.

Para agregar el campo Primario a través de la personalización

  1. En su aplicación, seleccione el icono Configuración y, después, seleccione Configuración avanzada.

    Opción Configuración avanzada en el menú Configuración

    Se abre la página Administración de empresas.

  2. En la barra de navegación, seleccione Configuración y, a continuación, en Personalización, seleccione Personalizaciones.

  3. Seleccione Personalizar el sistema.

  4. En Componentes en Explorador de soluciones, expanda Entidades y, a continuación, expanda la tabla Product.

  5. Seleccione Formularios y, a continuación, abra el formulario Producto de tipo Main que se encuentra en estado Activo .

  6. En el editor de formularios, seleccione el campo Primario del Explorador de campos y arrástrelo a la sección Resumen del lado izquierdo del editor de formularios.

    Agregue el campo Primario al formulario Producto.

  7. Seleccione Guardar y, a continuación , Publicar.

Para agregar el campo Primario a través del Asistente para importación y exportación de soluciones

En la solución no administrada, agregue la siguiente fila en el formulario principal producto:

<row>
    <cell id="{faaa2942-4737-4721-9a19-7dcbf4eb2911}" showlabel="true" locklevel="0" colspan="2" solutionaction="Added">
        <control id="editableParentControl" classid="{270BD3DB-D9AF-4782-9025-509E298DEC0A}" datafieldname="parentproductid" disabled="false">
            <parameters>
                <DefaultViewId>{19d7f2e0-e427-40fb-85e8-53e7cef2b166}</DefaultViewId>
                <IsInlineNewEnabled>false</IsInlineNewEnabled>
                <DisableMru>true</DisableMru>
            </parameters>
        </control>
    </cell>
</row>

Problema 2: los campos Precio de lista, Costo estándar o Costo actual no respetan el valor de precisión de campo decimal admitido

Solución

No hay ninguna relación entre el campo Decimal Supported (Compatible con decimales) y list Price (Precio de lista). El valor definido en el campo Decimal Supported no afecta al valor de precisión del campo List Price . El valor de precisión decimal del campo Precio de lista, Costo estándar o Costo actual se controla mediante la configuración De precisión decimal de precios. De forma predeterminada, "Pricing Decimal Precision" está establecido en 2. Para obtener más información sobre esta configuración, consulte la pestaña Configuración del sistema General. Para obtener más información sobre la precisión decimal, consulte Precisión decimal en moneda y precios.

Problema 3: error al establecer el campo Cantidad en un valor decimal en los registros Order Product, Quote Product, Invoice Product

Solución

El campo Opción de venta de la cantidad del registro de artículos de lista de precios decide si el producto o el servicio se pueden ordenar en su totalidad, parcial o en ambos tipos de cantidades. Para poder escribir valores decimales en el campo Cantidad , asegúrese de que el campo Opción de venta de cantidad no esté establecido en Entero. Para obtener más información, vea Definir precios de productos con listas de precios y artículos de lista de precios.

Problema 4: error al abrir o guardar un registro de producto cuando el campo Decimal Supported tiene el valor > 2

Solución

Si el campo Cantidad a mano se usa en el formulario, el valor del campo Decimal Supported no debe ser mayor que la precisión de Quantity On Hand.

Para corregir este problema, vaya a Configuración>Personalizaciones>Entidades>Cantidad de campos>a mano. Asegúrese de que el valor precision es el mismo que el valor admitido decimal.