Solución de problemas con productos
Siga las instrucciones de este artículo para solucionar los problemas que podría tener al trabajar con productos en Dynamics 365 Sales.
Problema 1: La reparentación no funciona o el campo Primario no está visible
La reparentación del producto le permite cambiar el elemento primario de un registro de producto existente para que los productos secundarios hereden las propiedades adecuadas del producto. Para obtener más información, vea Cambiar el elemento primario de un producto.
Causa
Si no ve el campo Primario en el formulario Producto, podría deberse a que ha personalizado el formulario Principal del producto mediante la solución no administrada. Para obtener más información, consulte Introducción a las soluciones.
En algunos casos, los formularios de producto no se combinan correctamente y, debido a esto, el campo Primario necesario no se agrega al formulario.
Solución
Para resolver esto, debe volver a agregar el campo Primario al formulario. Puede hacerlo mediante la personalización o mediante el asistente para importación y exportación de soluciones. Para obtener más información, consulte Exportación de soluciones e Importación de soluciones.
Para agregar el campo Primario mediante la personalización
En la aplicación, seleccione el icono Configuración y, a continuación, seleccione Configuración avanzada.
Se abre la página Administración de negocios .
En la barra de navegación, seleccione Configuración y, en Personalización, seleccione Personalizaciones.
Seleccione Personalizar el sistema.
En Componentes de Explorador de soluciones, expanda Entidades y, a continuación, expanda la tabla Producto.
Seleccione Formularios y, a continuación, abra el formulario Producto del tipo Principal que se encuentra en estado Activo .
En el editor de formularios, seleccione el campo Primario del Explorador de campos y arrástrelo a la sección Resumen del lado izquierdo del editor de formularios.
Seleccione Guardar y, a continuación, Publicar.
Para agregar el campo Primario a través del Asistente para importación y exportación de soluciones
En la solución no administrada, agregue la fila siguiente en el formulario Principal del producto:
<row>
<cell id="{faaa2942-4737-4721-9a19-7dcbf4eb2911}" showlabel="true" locklevel="0" colspan="2" solutionaction="Added">
<control id="editableParentControl" classid="{270BD3DB-D9AF-4782-9025-509E298DEC0A}" datafieldname="parentproductid" disabled="false">
<parameters>
<DefaultViewId>{19d7f2e0-e427-40fb-85e8-53e7cef2b166}</DefaultViewId>
<IsInlineNewEnabled>false</IsInlineNewEnabled>
<DisableMru>true</DisableMru>
</parameters>
</control>
</cell>
</row>
Problema 2: los campos Precio de lista, Costo estándar o Costo actual no respetan el valor de precisión de campo compatible con decimales
Solución
No hay ninguna relación entre el decimal admitido y el campo Precio de lista . El valor definido en el campo Compatible con decimales no afecta al valor de precisión del campo Precio de lista. El valor de precisión decimal del campo Precio de lista, Costo estándar o Costo actual se controla mediante la configuración Precisión decimal de precios . De forma predeterminada, "Precisión decimal de precios" se establece en 2. Para obtener más información sobre esta configuración, consulte la pestaña Configuración general del sistema. Para obtener más información sobre la precisión decimal, vea Precisión decimal en moneda y precios.
Problema 3: se produce un error al establecer el campo Cantidad en un valor decimal en los registros Producto de pedido, Producto de oferta, Producto de factura
Solución
El campo Opción de venta de cantidad del registro de artículos de lista de precios decide si el producto o servicio se puede ordenar en cantidades totales, parciales o en ambos tipos de cantidades. Para poder especificar valores decimales en el campo Cantidad , asegúrese de que el campo Opción de venta de cantidad no esté establecido en Entero. Para obtener más información, consulte Definición de precios de productos con listas de precios y artículos de lista de precios.
Problema 4: error al abrir o guardar un registro de producto cuando el campo Compatible con decimales tiene el valor > 2
Solución
Si el campo Cantidad a mano se usa en el formulario, el valor del campo Compatible con decimales no debe ser mayor que la precisión de Cantidad a mano.
Para solucionar este problema, vaya a Configuración>Personalizaciones> Cantidad decampos> deentidades>a mano. Asegúrese de que el valor precision es el mismo que el valor compatible con decimales .