Solucionar problemas con la previsión
Este artículo le ayuda a solucionar problemas relacionados con la previsión en Microsoft Dynamics 365 Sales.
Problema 1: se muestra un error al intentar crear una previsión basada en territorio
Síntomas
Al intentar crear una previsión basada en territorio, se muestra un error. Además, es posible que los datos de una previsión basada en territorio no se actualicen.
Causa
Cuando se realizan actualizaciones del sistema, la jerarquía de la entidad de territorio está deshabilitada (aunque la ha habilitado anteriormente), lo que provoca este error.
Solución
Para resolver este problema, debe habilitar la jerarquía en la definición de relación territory_parent_territory de Relaciones. Siga estos pasos:
Vaya a Configuración avanzada.
La página de configuración avanzada se abre en una pestaña.
Seleccione Personalizaciones de personalización>de configuración.>
Se abre la página de configuración de Power Apps .
Seleccione Entidades de datos>y, a continuación, seleccione Territorio.
En la página Territorio , seleccione la pestaña Relaciones y, a continuación, seleccione Primario.
En el cuadro de diálogo Varios a uno , active la casilla Jerárquico y, a continuación, seleccione Listo.
Guarde y cierre la entidad.
Problema 2: no se puede ocultar el campo de categoría de previsión en formularios de oportunidad
Causa
A veces, la aplicación muestra el campo Categoría de previsión en formularios de oportunidad, incluso después de que se haya configurado como invisible de forma predeterminada a través de personalizaciones de formularios.
Solución
Para resolver este error, debe eliminar el campo Categoría de previsión del formulario. Siga estos pasos:
En su aplicación, en la barra de navegación, seleccione el icono Configuración y, después, Configuración avanzada.
La página Configuración de la administración de empresas se abre en una nueva pestaña del explorador.
En la barra de navegación, seleccione Configuración y, en Personalización, seleccione Personalizaciones.
Seleccione Personalizar el sistema.
En Componentes en el Explorador de soluciones, expanda Entidades, Oportunidades y, a continuación, seleccione Formularios.
Abra el formulario Oportunidad de tipo Main.
El formulario de oportunidad se abre en una nueva ventana.
En la sección Resumen , seleccione el campo Categoría previsión y, a continuación, seleccione Quitar.
Guarde y publique la configuración.
Problema 3: no se pueden ver las previsiones
Causa
Si estaba usando la versión anterior de la previsión y se actualizó a la más reciente, es posible que el mapa del sitio de previsión no se actualice. Esto puede deberse a la presencia de una capa no administrada de la aplicación Sales Hub, lo que permitiría que el mapa del sitio de previsión abra la versión anterior de previsión.
La imagen siguiente es un ejemplo de la versión anterior de la página principal de previsión.
Solución
Para resolver este problema, actualice la entrada del mapa del sitio de previsión a la cuadrícula de entrada de previsión más reciente. Para obtener más información, consulte Adición de opciones de configuración y cuadrícula de previsión en el mapa del sitio.
Problema 4: no se puede cargar la cuadrícula de previsión y se muestra un error
Causa
El proceso ForecastInstanceActions se desactiva. El motivo podría ser que el propietario de una organización haya cambiado, lo que está causando el error al cargar la cuadrícula de previsión. Se muestra el error que se muestra en la imagen siguiente.
Acción (ForecastInstanceActions) para capturar previsiones se ha deshabilitado.
Solución
Para resolver este error, active el proceso ForecastInstanceActions . Siga estos pasos:
Vaya a Configuración avanzada y, a continuación, seleccione Configuración>procesos del Centro>de procesos.
En el cuadro de búsqueda, escriba ForecastInstanceActions. Puede ver que el proceso está en estado Borrador .
Seleccione el proceso y, a continuación, seleccione Activar.
En el mensaje de confirmación, seleccione Activar.
Compruebe que el estado del proceso está Activado y, a continuación, cierre Configuración.
Problema 5: no se pueden ver los datos detallados en una cuadrícula de previsión
Causa
No tiene suficientes privilegios para la entidad Forecast Configuration para ver los datos detallados en la cuadrícula de previsión. Se muestra el error que se muestra en la imagen siguiente.
Ha habido algún error.
Error al recuperar los registros de previsión.
Vuelva a cargar la página del explorador.
Solución
Para resolver este error, el administrador debe proporcionar privilegios de lectura en la entidad Forecast Configuration al rol de seguridad. Siga estos pasos:
Vaya a Configuración avanzada y, a continuación, seleccione Configuración>Roles de seguridad de seguridad>.
Seleccione el rol de seguridad para el que desea aplicar los privilegios.
En la página rol de seguridad, seleccione la pestaña Entidades personalizadas y vaya a la fila Configuración de previsión.
Seleccione y proporcione los privilegios de lectura.
Cierre la configuración.
Problema 6: los campos de categoría de previsión no se actualizan
Causa
En una previsión, después de actualizar el campo categoría de previsión a Ganado o Perdido, las oportunidades siguen apareciendo en el cubo de canalización anterior. Este error se produce porque el flujo de trabajo del proceso de asignación de categorías de previsión de oportunidades está deshabilitado en su organización.
Solución
Para resolver el error, active el flujo de trabajo proceso de asignación de categorías de previsión de oportunidades. Siga estos pasos:
Vaya a Configuración avanzada y seleccione Personalizaciones>de configuración> Personalizar el sistema.
En el mapa del sitio, seleccione Procesos.
Seleccione el flujo de trabajo Proceso de asignación de categorías de previsión de oportunidades y, a continuación, seleccione Activar.
Las categorías de previsión de las oportunidades se actualizarán correctamente. Las oportunidades que se cambiaron antes de activar el flujo de trabajo deben cambiarse manualmente. Además, abra el flujo de trabajo proceso de asignación de categorías de previsión de oportunidades y compruebe que las condiciones están definidas correctamente para cada categoría de previsión.
Guarde y cierre la configuración.
Problema 7: no se puede activar una previsión que tenga una columna relacionada con la jerarquía del tipo de búsqueda
Causa
Este problema se produce porque el usuario "Dynamics 365 Sales Forecasting" no tiene el permiso de lectura para la entidad de búsqueda relacionada con la jerarquía.
Solución
Para resolver el problema, siga los pasos siguientes:
Vaya a Configuración avanzada y seleccione Configuración>Roles de seguridad>del sistema>.
Abra el rol Forecast AppUser y seleccione la pestaña donde está presente el tipo de entidad.
Habilite el permiso De lectura en el nivel de organización para el tipo de entidad del campo de búsqueda.
Guarde los cambios.
Problema 8: no se puede activar una previsión
Causa
Se produce un error en la activación de la previsión debido a varios motivos.
Solución
Para resolver el problema, siga los pasos siguientes:
- Asegúrese de que ha realizado todas las configuraciones obligatorias para el modelo de previsión.
- Asegúrese de que los filtros de jerarquía de la configuración de previsión no filtren toda la jerarquía. Vaya a la sección Vista previa del paso General para asegurarse de que la jerarquía existe. Para obtener más información, consulte Adición de filtros adicionales a una previsión.
Problema 9: no se encuentra la opción de configuración de previsión en Configuración de la aplicación
Causa
Es posible que la opción de configuración de previsión no esté visible en la configuración de la aplicación del Centro de ventas debido a los siguientes motivos:
- No tiene el permiso de lectura para la entidad de configuración de previsión.
- El administrador no ha agregado manualmente la cuadrícula de previsión y la configuración en la sección Administración de rendimiento.
Solución
Para resolver el problema, siga estos pasos:
- Asigne el rol de seguridad forecast Manager al usuario que debe poder crear y administrar configuraciones de previsión.
- En Configuración de previsión, los elementos del panel de navegación de previsión deben agregarse en una aplicación personalizada.
Problema 10: no se pueden ver las previsiones de la jerarquía de usuarios
Causa
Este problema se produce debido a permisos insuficientes para ver la previsión.
Solución
Para resolver el problema, asegúrese de que:
Se cumple una de estas condiciones:
Usted es el propietario de la previsión. El campo Búsqueda del propietario del paso Permisos de la configuración de previsión muestra quién es el propietario.
Forma parte de los roles de seguridad que tienen el permiso de lectura, como se configura en el paso Permisos de la configuración de previsión.
Alguien ha compartido la previsión contigo. Para obtener más información, consulte Habilitar o deshabilitar el uso compartido de previsiones.
El campo Búsqueda del propietario del paso Permisos de la configuración de previsión no está establecido en Ninguno. Si se establece en Ninguno, nadie puede ver la previsión.
Problema 11: los valores del campo de previsión muestran cero o en blanco en la cuadrícula de previsión
Causa
Las columnas asociadas al campo Selector, Cantidad y Fecha pueden tener habilitada la seguridad de nivel de campo.
Solución
Para resolver el problema, debe conceder el permiso De lectura al usuario #Dynamics 365 Sales Forecasting en los perfiles de seguridad de campo. De lo contrario, la columna mostrará 0 a todos los usuarios. Siga estos pasos para configurar los perfiles de seguridad de campo:
- Vaya a Configuración Configuración avanzada>>Perfiles de seguridad de campo de seguridad.>
- Seleccione el perfil de seguridad de campo asociado al campo que muestra 0.
- Seleccione Usuarios>Agregar.
- Busque el usuario # Dynamics 365 Sales Forecasting , active la casilla con el nombre de usuario y, a continuación, seleccione Seleccionar>agregar.
- Seleccione Permisos de campo y conceda permiso de lectura al campo.
- Guarde y cierre el perfil.
Vuelva a calcular la previsión y compruebe que la columna muestra los valores adecuados.
Problema 12: no se puede volver a calcular manualmente la columna de predicción en la página Previsiones
Causa
La columna de predicción de la página Previsiones no se puede volver a calcular manualmente.
Solución
La columna de predicción de La previsión se vuelve a calcular automáticamente después de cada siete días y no admite la actualización manual. Esto se debe a que las predicciones se basan en modelos controlados por ia que examinan los datos históricos y la canalización de ventas abierta para predecir el resultado futuro de los ingresos. En la columna de predicción se muestran los ingresos previstos para cada vendedor y administrador en función del campo Estado de una oportunidad. Para optimizar la precisión de las predicciones, asegúrese de que los valores de Categoría de previsión se mantienen sincronizados con el campo Estado. Para la categoría de previsión predefinida, un flujo de trabajo asegura que cuando una oportunidad se cierra como Ganada o Perdida, la categoría de previsión se actualiza con el valor adecuado.
Problema 13: la vista de cuadrícula subyacente de previsión está deshabilitada (solo lectura) cuando se carga la página
Causa
Un JavaScript personalizado configurado en la configuración de previsión impide que la cuadrícula se pueda editar.
Solución
Para resolver el problema, revise el código JavaScript personalizado y compruebe si deshabilita la vista de cuadrícula de registros subyacentes.