Se produce un error de privilegios o permisos en microsoft Dynamics 365 App for Outlook
Este artículo ayuda a resolver los errores que se producen al intentar usar o abrir la aplicación De Microsoft Dynamics 365 para Outlook.
Se aplica a: Aplicación de Dynamics 365 para Outlook
Número de KB original: 4563997, 4229661
Síntoma 1
Al intentar usar Dynamics 365 App for Outlook, recibirá un error similar al siguiente:
No tiene privilegios necesarios (prvReadOrganization), que limita ciertas funcionalidades. Póngase en contacto con el administrador para obtener el acceso necesario.
Causa
Este error se produce si el usuario asociado al registro de buzón no tiene privilegios suficientes para usar la aplicación Dynamics 365 para Outlook.
Síntoma 2
Al abrir Dynamics 365 App for Outlook, recibirá el siguiente error:
Lo sentimos
No se puede mostrar la aplicación de Dynamics 365 para Outlook porque el rol de usuario actual no tiene permisos necesarios. Póngase en contacto con el administrador para tener asignado el rol de seguridad necesario a la solución Dynamics 365 App for Outlook.
Si selecciona Mostrar más, los detalles adicionales incluyen la siguiente información:
Error: No tiene permisos para recuperar appforOutlookModule id.
Seguimiento: Error: No tiene permisos para recuperar el identificador appforOutlookModule en el nuevo ...
Causa
Este error se produce si el rol de seguridad de Dynamics 365 no tiene acceso al módulo de aplicación que usa la aplicación Dynamics 365 para Outlook.
Solución
Para resolver estos problemas, use una de las siguientes opciones.
Opción 1: Asignar el rol de seguridad "Dynamics 365 App for Outlook User"
El rol de seguridad de usuarios de Dynamics 365 App for Outlook se puede asignar a los usuarios que necesitan usar la aplicación Dynamics 365 para Outlook. Este rol de seguridad está disponible en la compilación 9.1.0.4206 o posterior. Esta opción garantiza que los usuarios tengan los privilegios básicos necesarios para acceder a Dynamics 365 App for Outlook.
Opción 2: Asignación de privilegios a un rol de seguridad personalizado
Si prefiere personalizar un rol de seguridad para incluir los privilegios necesarios, consulte la sección Más información para obtener una lista de privilegios necesarios para usar Dynamics 365 App for Outlook.
Importante
Los roles de seguridad personalizados no tienen acceso al módulo de aplicaciones de Dynamics 365 de forma predeterminada. Los pasos proporcionados en paso 3: Proporcionar acceso a roles de seguridad también son necesarios.
Más información
En la tabla siguiente se enumeran los privilegios necesarios para usar la aplicación de Dynamics 365 para Outlook y la pestaña en un rol de seguridad donde se puede encontrar el privilegio.
Un usuario con el rol Administrador del sistema puede buscar y modificar un rol de seguridad; para ello, vaya a Configuración roles> de seguridad de seguridad.>
Para ver qué roles se asignan a un usuario específico, vaya a Configuración, seleccione Seguridad, seleccione Usuarios, seleccione el registro de usuario específico y, a continuación, seleccione Administrar roles.
Nombre de privilegio | Entidad | Ubicación (pestaña) dentro de rol de seguridad |
---|---|---|
prvReadEmailServerProfile | EmailServerProfile | Administración de empresas |
prvReadRole | Rol de seguridad | Administración de empresas |
prvReadUser | Usuario | Administración de empresas |
prvWriteMailbox | Buzón | Administración de empresas |
prvReadMailbox | Buzón | Administración de empresas |
prvReadOrganization | Organización | Administración de empresas |
prvSyncToOutlook (exchangesyncidmapping) | Sincronizar con Outlook | Administración de Empresas > Privilegios relacionados con la privacidad |
prvUseOfficeApps | Usar Dynamics 365 App for Outlook | Administración de Empresas > Privilegios relacionados con la privacidad |
prvAppendToAccount | de GitHub | Registros principales |
prvReadAccount | de GitHub | Registros principales |
prvDeleteActivity | Actividad | Registros principales |
prvAppendActivity | Actividad | Registros principales |
prvWriteActivity | Actividad | Registros principales |
prvCreateActivity | Actividad | Registros principales |
prvReadActivity | Actividad | Registros principales |
prvAppendToActivity | Actividad | Registros principales |
prvShareActivity | Activity | Registros principales |
prvAppendToContact | Contact | Registros principales |
prvReadContact | CONTACTO | Registros principales |
prvCreateContact | CONTACTO | Registros principales |
prvReadUserQuery | Vista guardada | Registros principales |
prvReadAppModule | Aplicación basada en modelo | Personalización |
prvReadAttribute | Campo | Personalización |
prvReadEntity | Entidad | Personalización |
prvReadRelationship | Relación | Personalización |
prvReadSystemApplicationMetadata | Metadatos de aplicación del sistema | Personalización |
prvReadSystemForm | Formulario del sistema | Personalización |
prvReadUserApplicationMetadata | Metadatos de aplicación del usuario | Personalización |
prvReadQuery | Vista | Personalización |
prvReadWebResource | Recurso web | Personalización |
prvSearchAvailability | Buscar disponibilidad | Administración de servicios > Privilegios varios |
En la tabla siguiente se enumeran los privilegios adicionales necesarios para ver algunas de las vistas predeterminadas que se usan dentro de los formularios de Dynamics 365 App for Outlook. Sin estos privilegios, un usuario podría ver el siguiente error en lugar de la vista esperada (subgrid) de registros:
No tiene permiso para acceder a estos registros. Póngase en contacto con el administrador de Microsoft Dynamics 365 para obtener ayuda.
Nombre de privilegio | Entidad | Ubicación (pestaña) dentro de rol de seguridad |
---|---|---|
prvReadIncident | Case | Servicio |
prvReadOpportunity | Muestra de análisis | Registros principales |
prvReadCompetitor | Competidor | Ventas |
prvReadConnection | Conexión | Registros principales |