No se puede eliminar una solución administrada que consta de una entidad habilitada para el Acuerdo de Nivel de Servicio
En este artículo se proporciona una solución para el problema en el que no se puede eliminar una solución administrada que consta de una entidad habilitada para el Acuerdo de Nivel de Servicio (SLA) de Dynamics 365.
Síntomas
No se puede eliminar una solución administrada que contenga una entidad con un Acuerdo de Nivel de Servicio habilitado en ella. Esta entidad se ha creado como parte de una solución importada anteriormente.
Causa
Una vez habilitada en una entidad, no se puede deshabilitar un Acuerdo de Nivel de Servicio.
Use este ejemplo para comprender el problema:
- Cree una solución nueva en Org1 y llámela Solución de campo.
- Cree una nueva entidad en Solución de campo y llámela Trabajo de campo.
- Exporte Solución de campo como solución administrada.
- Importe Solución de campo a una nueva organización llamada Org2.
Siguiente:
- Cree otra solución en Org1 y llámela Solución de campo Delta.
- Asocie la entidad Trabajo de campo con Solución del campo Delta. Habilite el Acuerdo de Nivel de Servicio en la entidad.
- Exporte Solución de campo Delta como solución administrada.
- Importe Solución de campo Delta en Org2.
Ahora, si intenta eliminar la solución Delta Field de Org2, no puede eliminarla porque tiene una entidad de trabajo Field asociada a ella que tiene habilitado el Acuerdo de Nivel de Servicio.
Solución
Para eliminar una solución administrada con una entidad habilitada por SLA, primero debe eliminar la solución administrada anteriormente importada que creó la entrada de la entidad. Esta acción garantiza que se elimine la entrada de entidad. A continuación, puede crear la entidad de nuevo o volver a importar la solución administrada.
Para eliminar la solución Delta Field en Org2, elimine primero la solución Field.
La solución de campo se puede eliminar porque la entidad asociada a ella (Trabajo de campo) no tiene habilitado el Acuerdo de Nivel de Servicio. La eliminación de la solución Field garantiza que se eliminen la configuración del Acuerdo de Nivel de Servicio y la entidad.
Nota:
Esta solución alternativa no funcionará para las entidades integradas porque no se pueden eliminar entidades integradas ni soluciones administradas asociadas a ellas.