Error al intentar actualizar el agente de MARS: error en la actualización del agente de Microsoft Azure Recovery Services
En este artículo se describen los síntomas y la resolución de un problema que se produce al intentar actualizar de una versión anterior a una versión más reciente o a una versión más reciente del agente de Microsoft Azure Recovery Services (MARS).
Versión original del producto: Azure Site Recovery
Número de KB original: 4020490
Síntomas
Al intentar actualizar el agente de MARS mediante el Asistente para actualización del agente de Microsoft Azure Recovery Services, se produce un error en la actualización y recibe el siguiente mensaje de error:
Error en la actualización del agente de Microsoft Azure Recovery Service.
Error: No se puede iniciar RecoveryServicesManagementAgent Service. Desinstalación de la revisión
Problema: error al actualizar la instalación con el error 1612
Causa
Este problema se produce porque la actualización no encuentra el instalador de origen para el agente de MARS en la memoria caché de Windows Installer. El instalador de origen es necesario para que la actualización se complete correctamente.
Solución
Para corregir este problema, asegúrese de que el instalador de origen existe en la memoria caché de Windows Installer. Para ello, siga estos pasos:
Salga del Asistente para actualización del agente de Microsoft Azure Recovery Services.
Abra el archivo OBPatch.log que se encuentra en la
C:\Windows\Temp
carpeta .Busque la línea de descripción de error en el archivo OBPatch.log que busca "Advertencia: Paquete almacenado en caché local".
Busque una línea similar a la siguiente: Advertencia:
Falta el paquete en caché local "C:\Windows\Installer\Unique_ID.msi.
Tenga en cuenta theUnique_IDvalue para futuras referencias.
Haga doble clic en el archivo del instalador de actualización del agente de MARS (.exe). Esto copia todos los archivos binarios y instaladores relacionados con la instalación en una ubicación temporal del equipo y abre el Asistente para actualización del agente de Microsoft Azure Recovery Services.
Nota Deje abierto el asistente hasta el paso 12.
Abra el archivo OBInstaller0Curr.errlog que se encuentra en la carpeta "C:\Windows\Temp".
Busque en el texto "Ruta de acceso de directorio para SetupLaunchScreen" y busque la línea con la marca de tiempo más reciente similar a la siguiente: Ruta de acceso de directorio para SetupLaunchScreen:
C:\Temp_ID
.Vaya a la carpeta
C:\Temp_ID\Installers
.En esta carpeta, busque y copie el archivo OBSAGENT.msi en la carpeta C:\Windows\Installer. Cambie el nombre del archivo de destino como Unique_ID.msi.
Cierre el Asistente para actualización del agente de MARS.
Ejecute el instalador de actualización para instalar la actualización. Si el problema persiste, póngase en contacto con el servicio de soporte técnico de Microsoft.
Ponte en contacto con nosotros para obtener ayuda
Si tiene preguntas o necesita ayuda, cree una solicitud de soporte o busque consejo en la comunidad de Azure. También puede enviar comentarios sobre el producto con los comentarios de la comunidad de Azure.