Compartir a través de


Solución de problemas del código de error "PublicIPCountLimitReached"

En este artículo se explica cómo identificar y resolver el error "PublicIPCountLimitReached". Este error se produce al intentar crear, actualizar o actualizar un clúster de Azure Kubernetes Service (AKS). Este error también puede deberse a cualquier otra acción que desencadene la creación de una dirección IP pública, como la implementación de un equilibrador de carga público de tipo de servicio de Kubernetes.

Síntomas

Se produce un error en una operación de creación, actualización, actualización, actualización u otra operación de clúster de AKS que desencadena la creación de una dirección IP pública, como la implementación de un servicio de Kubernetes que tiene un equilibrador de carga público y devuelve un mensaje de error "PublicIPCountLimitReached".

Causa

Este error se produce si ha alcanzado el número máximo de direcciones IP públicas permitidas para la suscripción. El límite varía en función del tipo de suscripción. Para obtener más información sobre los límites de direcciones IP públicas, consulte esta guía detallada.

Solución

Para aumentar el límite o la cuota de direcciones IP públicas de la suscripción, siga estos pasos:

  1. Vaya a Azure Portal y seleccione las suscripciones para las que va a realizar la operación.

  2. En la sección Configuración , seleccione Uso y cuotas. Establezca el proveedor en Redes y, opcionalmente, filtre por la región del clúster de AKS.

  3. Busque el registro De direcciones IP públicas. En la misma línea, seleccione el botón Crear una nueva solicitud de soporte técnico.

    Captura de pantalla que muestra cómo crear una solicitud de soporte técnico para el aumento de cuota.

  4. En la página Nueva solicitud de soporte técnico, especifique el nuevo límite que necesita y siga las instrucciones para crear la solicitud de soporte técnico.

    Captura de pantalla que indica cómo especificar el nuevo límite para las direcciones IP públicas.

Una vez que el cambio de cuota surte efecto, vuelva a intentar la operación que desencadenó inicialmente el error "PublicIPCountLimitReached".

Ponte en contacto con nosotros para obtener ayuda

Si tiene preguntas o necesita ayuda, cree una solicitud de soporte o busque consejo en la comunidad de Azure. También puede enviar comentarios sobre el producto con los comentarios de la comunidad de Azure.