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La dirección IP del cliente no puede acceder al servidor de API

En este artículo se describe cómo corregir problemas que se producen cuando no se puede conectar a un clúster de Azure Kubernetes Service (AKS) porque la dirección IP del cliente no puede acceder al servidor de API de AKS.

Requisitos previos

Síntomas

Al intentar acceder a recursos de Kubernetes, como mamespaces y cargas de trabajo desde Azure Portal, es posible que encuentre los siguientes errores:

Error de red

No se puede acceder al servidor de API "https://< API-server-FQDN>" o el servidor de API está demasiado ocupado para responder. Compruebe la configuración de red y actualice para intentarlo de nuevo.

Captura de pantalla de mamespaces en el recurso de AKS.

Causa

Los intervalos IP autorizados por el servidor de API pueden haberse habilitado en el servidor de API del clúster, pero la dirección IP del cliente no se incluyó en los intervalos IP. Para comprobar si esta característica se ha habilitado, consulte si el siguiente comando az aks show en la CLI de Azure genera una lista de intervalos IP:

az aks show --resource-group <cluster-resource-group> \
    --name <cluster-name> \
    --query apiServerAccessProfile.authorizedIpRanges

Solución

Examine los intervalos autorizados por el servidor de API del clúster y agregue la dirección IP del cliente dentro de ese intervalo.

Nota:

  1. ¿Tiene acceso al servidor de API desde una red corporativa donde se enruta el tráfico a través de un servidor proxy o un firewall? Después, pida al administrador de red antes de agregar la dirección IP del cliente a la lista de intervalos autorizados para el servidor de API.

  2. Pregunte también al administrador del clúster antes de agregar la dirección IP del cliente, ya que puede haber problemas de seguridad al agregar una dirección IP temporal a la lista de intervalos autorizados.

  1. Vaya al clúster desde Azure Portal.

  2. En el menú de la izquierda, busque Configuración y, a continuación, seleccione Redes.

  3. En la página Redes , seleccione la pestaña Información general .

  4. Seleccione Administrar en Configuración de recursos.

  5. En el panel Intervalos IP autorizados, agregue la dirección IP del cliente como se muestra en la captura de pantalla siguiente:

    Captura de pantalla del panel Authorized-ip-ranges (Intervalos ip autorizados).

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