Error AADSTS650056: aplicación mal configurada
En este artículo se describe un problema en el que recibe el siguiente mensaje de error al intentar iniciar sesión en una aplicación configurada con el inicio de sesión único (SSO) basado en SAML que se ha integrado con microsoft Entra ID:
Error AADSTS650056: aplicación mal configurada. Esto puede deberse a uno de los siguientes motivos: el cliente no ha enumerado ningún permiso para "{name}" en los permisos solicitados en el registro de aplicación del cliente. O bien el administrador no ha dado su consentimiento en el inquilino. O bien, compruebe también el identificador de la aplicación en la solicitud para asegurarse de que coincide con el identificador de la aplicación cliente configurada. O bien, compruebe el certificado en la solicitud para asegurarse de que es válido. Póngase en contacto con su administrador para corregir la configuración o dar su consentimiento en nombre del inquilino. Identificador de la aplicación cliente: {id} Póngase en contacto con su administrador para corregir la configuración o dar su consentimiento en nombre del inquilino.
Síntomas
Recibe un error AADSTS650056
al intentar iniciar sesión en una aplicación que se ha configurado para usar Microsoft Entra ID para la administración de identidades mediante el inicio de sesión único basado en SAML.
Causa
El Issuer
atributo enviado desde la aplicación a Microsoft Entra ID en la solicitud SAML no coincide con el valor identificador configurado para la aplicación en Microsoft Entra ID.
Solución
Asegúrese de que el Issuer
atributo de la solicitud SAML coincide con el valor identificador configurado en Microsoft Entra ID.
Compruebe que el valor del cuadro de texto Identificador coincide con el valor del identificador mostrado en el error.
Para obtener más información sobre el atributo Issuer, consulte Protocolo SAML de inicio de sesión único.
Más información
Para obtener una lista completa de los códigos de error de autenticación y autorización de Active Directory, consulte Códigos de error de autenticación y autorización de Microsoft Entra.
Ponte en contacto con nosotros para obtener ayuda
Si tiene preguntas o necesita ayuda, cree una solicitud de soporte o busque consejo en la comunidad de Azure. También puede enviar comentarios sobre el producto con los comentarios de la comunidad de Azure.