Error AADSTS50011 con la autenticación SAML: la dirección URL de respuesta especificada en la solicitud no coincide
En este artículo se proporciona una resolución al error de AADSTS50011 que se produce durante la autenticación federada con el identificador de Microsoft Entra.
Síntomas
Aparece un error AADSTS50011
al intentar iniciar sesión en una aplicación que se ha configurado para usar Microsoft Entra ID para la administración de identidades mediante el inicio de sesión único basado en SAML.
Error AADSTS50011: la dirección URL de respuesta no coincide con las direcciones URL de respuesta configuradas para el GUID> de la aplicación<. Asegúrese de que la dirección URL de respuesta enviada en la solicitud coincide con una agregada a la aplicación en Azure Portal. Vaya a para https://aka.ms/urlMismatchError obtener más información sobre cómo corregir esto". al intentar iniciar sesión en una aplicación configurada con el inicio de sesión único (SSO) basado en SAML que se ha integrado con microsoft Entra ID.
Causa
El AssertionConsumerServiceURL
valor de la solicitud SAML no coincide con el valor o el patrón de dirección URL de respuesta configurado en Microsoft Entra ID. El valor de AssertionConsumerServiceURL
en la solicitud SAML es la dirección URL que aparece en el error.
Solución
Para resolver el problema, siga estos pasos:
- Asegúrese de que el
AssertionConsumerServiceURL
valor de la solicitud SAML coincide con el valor url de respuesta configurado en Microsoft Entra ID. - Compruebe o actualice el valor en el cuadro de texto Dirección URL de respuesta para que coincida con el valor de
AssertionConsumerServiceURL
en la solicitud SAML.
Por ejemplo, consulte el siguiente artículo para obtener pasos detallados sobre cómo configurar los valores en Microsoft Entra ID:
Nota:
La dirección URL de respuesta también se conoce como URI de redirección. Estos valores dependen de qué aplicación se usa. El proveedor de la aplicación le proporcionará estos valores.
Después de actualizar el valor url de respuesta en Microsoft Entra ID y coincide con el valor enviado por la aplicación en la solicitud SAML, debería poder iniciar sesión en la aplicación.
Más información
Para obtener una lista completa de los códigos de error de autenticación y autorización de Active Directory, consulte Códigos de error de autenticación y autorización de Microsoft Entra.
Ponte en contacto con nosotros para obtener ayuda
Si tiene preguntas o necesita ayuda, cree una solicitud de soporte o busque consejo en la comunidad de Azure. También puede enviar comentarios sobre el producto con los comentarios de la comunidad de Azure.