Solución de problemas de Integration Runtime autohospedado (SHIR) de Microsoft Purview
En este artículo se exploran los métodos comunes de solución de problemas de Integration Runtime autohospedado (SHIR) en Microsoft Purview.
El entorno de ejecución de integración autohospedado (SHIR) también lo usan Azure Data Factory y Azure Synapse Analytics. Aunque muchos de los pasos de solución de problemas se superponen, siga esta guía para solucionar problemas de SHIR para esos productos:
Recopilación de registros de entorno de ejecución de integración autohospedados específicos de Microsoft Purview
En el caso de los exámenes de Microsoft Purview con errores que se ejecutan en una instancia de IR autohospedada, el servicio admite la visualización y carga de registros de errores desde la Visor de eventos de Windows.
Puede buscar los errores que vea en la guía de errores siguiente. Para obtener instrucciones de soporte técnico y solución de problemas de SHIR, es posible que tenga que generar un identificador de informe de errores y ponerse en contacto con el soporte técnico de Microsoft.
Para generar el identificador del informe de errores para Soporte técnico de Microsoft, siga estas instrucciones:
Antes de iniciar un examen en el portal de gobernanza de Microsoft Purview:
- Vaya a la máquina donde está instalado el entorno de ejecución de integración autohospedado y abra el Visor de eventos de Windows.
- Borre los registros del visor de eventos de Windows en la sección Integration Runtime. Haga clic con el botón derecho en los registros y seleccione la opción borrar registros.
- Vuelva al portal de gobernanza de Microsoft Purview e inicie el examen.
Una vez que el examen muestre el estado Error, vuelva a la máquina virtual de SHIR o al equipo y actualice el visor de eventos en la sección Integration Runtime.
Los registros de actividad se muestran para la ejecución del examen con errores.
Para obtener más ayuda de Microsoft, seleccione Enviar registros.
Se abre la ventana Compartir los registros de Integration Runtime autohospedado (SHIR) con Microsoft .
Cuando se carguen los registros, mantenga un registro del identificador de informe que se usará si se comunica con el soporte técnico de Microsoft.
Error o error general de SHIR del entorno de ejecución de integración autohospedado
Hay muchos errores, advertencias y problemas comunes entre el SHIR de Purview, Azure Data Factory o Azure Synapse SHIR. En la guía siguiente se tratan muchos de los problemas más comunes.
Error o error general de IR autohospedado
Problema de memoria insuficiente
Síntomas
Se produce un error de OutOfMemoryException (OOM) al intentar ejecutar un examen con una instancia de IR autohospedada.
Causa
Un nuevo examen puede producir un error de OOM si la máquina de IR experimenta un uso momentáneo de memoria alta. El problema puede deberse a un gran volumen de actividad simultánea o a una cantidad baja de memoria y el error es por diseño.
Resolución
Compruebe el uso de recursos para confirmar si se está ejecutando cualquier otro software al mismo tiempo y confirme que la máquina SHIR cumple las configuraciones recomendadas.
Ir autohospedado no pudo cargar el archivo o ensamblado
Síntomas
Aparece el siguiente mensaje de error:
"No se pudo cargar el archivo o ensamblado 'XXXXXXXXXXXXXXXX, Version=4.0.2.0, Culture=neutral, PublicKeyToken=XXXXXXXXX' o una de sus dependencias. El sistema no puede encontrar el archivo especificado. Id. de actividad: 92693b45-b4bf-4fc8-89da-2d3dc56f27c3"
Este es un mensaje de error más específico:
"No se pudo cargar el archivo o ensamblado 'System.ValueTuple, Version=4.0.2.0, Culture=neutral, PublicKeyToken=XXXXXXXXX' o una de sus dependencias. El sistema no puede encontrar el archivo especificado. Id. de actividad: 92693b45-b4bf-4fc8-89da-2d3dc56f27c3"
Causa
En Monitor de procesos, puede ver el siguiente resultado:
Sugerencia
En Monitor de procesos, puede establecer filtros como se muestra en la siguiente captura de pantalla. El mensaje de error anterior indica que el archivo DLL System.ValueTuple no se encuentra en la carpeta caché global de ensamblados (GAC) relacionada, en la carpeta C:\Program Files\Microsoft Integration Runtime\4.0\Gateway o en la carpeta C:\Program Files\Microsoft Integration Runtime\4.0\Shared. Básicamente, el proceso carga el archivo DLL primero desde la carpeta GAC , después desde la carpeta Shared y, por último, desde la carpeta Gateway . Por lo tanto, puede cargar el archivo DLL desde cualquier ruta de acceso que sea útil.
Resolución
Encontrará el archivo System.ValueTuple.dll en la carpeta C:\Archivos de programa\Microsoft Integration Runtime\4.0\Gateway\DataScan. Para resolver el problema, copie el archivo System.ValueTuple.dll en la carpeta C:\Archivos de programa\Microsoft Integration Runtime\4.0\Gateway.
Puede usar el mismo método para resolver otros problemas de archivo o ensamblado que faltan.
Más información
La razón por la que ve el System.ValueTuple.dll en %windir%\Microsoft.NET\assembly y %windir%\assembly es que se trata de un comportamiento de .NET.
En el siguiente error, puede ver claramente que falta el ensamblado System.ValueTuple . Este problema surge cuando la aplicación intenta comprobar el ensamblado System.ValueTuple.dll .
"<LogProperties><ErrorInfo>[{"Code":0,"Message":"El inicializador de tipo para 'Npgsql.PoolManager' produjo una excepción.","EventType":0,"Category":5,"Data":{},"MsgId":null,"ExceptionType":"System.TypeInitializationException","Source":"Npgsql","StackTrace":"","InnerEventInfos":[{"Code":0,"Message":"Could not load file or assembly 'System.ValueTuple, Version=4.0.2.0, Culture=neutral, PublicKeyToken=XXXXXXXXX' o una de sus dependencias. El sistema no puede encontrar el archivo especificado.","EventType":0,"Category":5,"Data":{},"MsgId":null,"ExceptionType":"System.IO.FileNotFoundException","Source":"Npgsql","StackTrace":","InnerEventInfos":[]}]}]</ErrorInfo></LogProperties>"
Para obtener más información sobre GAC, consulte Caché global de ensamblados.
Falta la clave de autenticación del entorno de ejecución de integración autohospedado
Síntomas
El entorno de ejecución de integración autohospedado se desconecta repentinamente sin una clave de autenticación y el registro de eventos muestra el siguiente mensaje de error:
"Todavía no se ha asignado la clave de autenticación"
Causa
Se eliminó el nodo ir autohospedado o ir autohospedado lógico en el portal de Microsoft Purview o se realizó una desinstalación limpia.
Resolución
Si no se aplica ninguna de las causas anteriores, puede ir a la carpeta %programdata%\Microsoft\Data Transfer\DataManagementGateway para ver si se ha eliminado el archivo Configurations . Si se eliminó, siga las instrucciones del artículo de Netwrix Detectar quién eliminó un archivo de los servidores de archivos de Windows.
No se puede elegir el certificado porque falta la clave privada.
Síntomas
- Ha importado un archivo PFX al almacén de certificados.
- Cuando seleccionó el certificado a través de la interfaz de usuario de Configuration Manager IR, recibió el siguiente mensaje de error:
"No se pudo cambiar el modo de cifrado de comunicación de intranet. Es probable que el certificado "<nombre> del certificado" no tenga una clave privada capaz de intercambiar claves o que el proceso no tenga derechos de acceso para la clave privada. Consulte la excepción interna para obtener más detalles".
Causa
- La cuenta de usuario tiene un nivel de privilegios bajo y no puede acceder a la clave privada.
- El certificado se generó como una firma, pero no como un intercambio de claves.
Resolución
- Para operar la interfaz de usuario, use una cuenta con los privilegios adecuados para acceder a la clave privada.
- Importe el certificado ejecutando el siguiente comando:
certutil -importpfx FILENAME.pfx AT_KEYEXCHANGE
Mensaje de error UserErrorJreNotFound al ejecutar un examen
Síntomas
Al intentar examinar un origen de datos mediante una herramienta o programa basado en Java (por ejemplo, archivos de formato Parquet), recibe un mensaje de error similar al siguiente:
ErrorCode=UserErrorJreNotFound,'Type=Microsoft.DataTransfer.Common.Shared.HybridDeliveryException,Message=Java Runtime Environment no se encuentra. Vaya a
http://go.microsoft.com/fwlink/?LinkId=808605
para descargar e instalar en la máquina del nodo de Integration Runtime (autohospedado). Nota: el Integration Runtime de 64 bits requiere JRE de 64 bits y Integration Runtime de 32 bits requiere JRE.,Source=Microsoft.DataTransfer.Common,''Type=System.DllNotFoundException,Message=Unable to load DLL 'jvm.dll': No se encontró el módulo especificado. (Excepción de HRESULT: 0x8007007E),Source=Microsoft.DataTransfer.Richfile.HiveOrcBridge
Causa
Este problema se produce por cualquiera de los siguientes motivos:
Java Runtime Environment (JRE) no está instalado correctamente en el servidor de Integration Runtime.
El servidor Integration Runtime carece de la dependencia necesaria para JRE.
De forma predeterminada, Integration Runtime resuelve la ruta de acceso de JRE mediante entradas del Registro. Estas entradas se deben establecer automáticamente durante la instalación de JRE.
Resolución
Siga atentamente los pasos de esta sección. La modificación incorrecta del Registro puede producir graves problemas. Antes de modificarlo, realice una copia de seguridad del Registro para efectuar una restauración en caso de que surjan problemas.
Para corregir este problema, siga estos pasos para comprobar el estado de la instalación de JRE:
Asegúrese de que Integration Runtime (Diahost.exe) y JRE están instalados en la misma plataforma. Compruebe las condiciones siguientes:
JRE de 64 bits para ADF de 64 bits Integration Runtime debe instalarse en la carpeta :
C:\Program Files\Java\
Nota:
La carpeta no es
C:\Program Files (x86)\Java\
JRE 11 es compatible con el escaneo. JRE 8 también es compatible, pero las versiones anteriores a JRE 8 no se han validado para este uso.
Compruebe la configuración adecuada en el registro. Para ello, siga estos pasos:
En el menú Ejecutar , escriba Regedit y presione Entrar.
En el panel de navegación, busque la siguiente subclave:
HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment
.En el panel Detalles , debe haber una entrada Versión actual que muestre la versión de JRE (por ejemplo, 1.8).
En el panel de navegación, busque una subclave que sea una coincidencia exacta para la versión (por ejemplo, 1.8) en la carpeta JRE. En el panel de detalles, debe haber una entrada JavaHome . El valor de esta entrada es la ruta de instalación de JRE.
Busque la carpeta bin\server en la ruta de acceso siguiente:
C:\Program Files\Java\jre1.xx.xxx
Compruebe si esta carpeta contiene un archivo jvm.dll. Si no es así, busque el archivo en la
bin\client
carpeta .
Nota:
- Si alguna de estas configuraciones no es como se describe en estos pasos, use el instalador de Windows de JRE para solucionar los problemas.
- Si todas las configuraciones de estos pasos son correctas como se describe, puede que falte una biblioteca en tiempo de ejecución de VC++ en el sistema. Para solucionar este problema, instale el paquete redistribuible de VC++ 2010.
Configuración de IR autohospedado
Error de registro de Integration Runtime
Síntomas
En ocasiones, es posible que desee ejecutar una instancia de IR autohospedada en una cuenta diferente por cualquiera de las siguientes razones:
- La directiva de empresa no permite la cuenta de servicio.
- Se requiere cierta autenticación.
Después de cambiar la cuenta de servicio en el panel de servicio, es posible que descubra que integration runtime deja de funcionar y recibe el siguiente mensaje de error:
"El nodo Integration Runtime (autohospedado) ha encontrado un error durante el registro. No se puede conectar al servicio host de Integration Runtime (autohospedado)."
Causa
Muchos recursos solo se conceden a la cuenta de servicio. Al cambiar la cuenta de servicio a otra cuenta, los permisos de todos los recursos dependientes permanecen sin cambios.
Resolución
Vaya al registro de eventos de Integration Runtime para comprobar el error.
Si el error en el registro de eventos es "UnauthorizedAccessException", haga lo siguiente:
Compruebe la cuenta de servicio de inicio de sesión DIAHostService en el panel de servicio de Windows.
Compruebe si la cuenta de servicio de inicio de sesión tiene permisos de lectura y escritura para la carpeta %programdata%\Microsoft\DataTransfer\DataManagementGateway .
De forma predeterminada, si no se ha cambiado la cuenta de inicio de sesión del servicio, debe tener permisos de lectura y escritura.
Si ha cambiado la cuenta de inicio de sesión del servicio, mitigue el problema haciendo lo siguiente:
- Realice una desinstalación limpia de la instancia de IR autohospedada actual.
- Instale los bits de IR autohospedados.
- Cambie la cuenta de servicio haciendo lo siguiente:
- Vaya a la carpeta de instalación de IR autohospedado y cambie a la carpeta Microsoft Integration Runtime\4.0\Shared.
- Abra una ventana del símbolo del sistema con privilegios elevados. Reemplace <usuario> y <contraseña> por su propio nombre de usuario y contraseña y, a continuación, ejecute el siguiente comando:
dmgcmd.exe -SwitchServiceAccount "<user>" "<password>"
- Si desea cambiar a la cuenta LocalSystem, asegúrese de usar el formato correcto para esta cuenta:
dmgcmd.exe -SwitchServiceAccount "NT Authority\System" ""
-
No use este formato:
dmgcmd.exe -SwitchServiceAccount "LocalSystem" ""
- Opcionalmente, dado que el sistema local tiene privilegios más altos que el administrador, también puede cambiarlo directamente en "Servicios".
- Puede usar un usuario local o de dominio para la cuenta de inicio de sesión del servicio IR.
- Registre el entorno de ejecución de integración.
Si el error es "Service 'Integration Runtime Service' (DIAHostService) no se pudo iniciar. Compruebe que tiene privilegios suficientes para iniciar los servicios del sistema", haga lo siguiente:
Compruebe la cuenta de servicio de inicio de sesión DIAHostService en el panel de servicio de Windows.
Compruebe si la cuenta de servicio de inicio de sesión tiene el permiso Iniciar sesión como servicio para iniciar el servicio de Windows:
Más información
Si no se aplica ninguno de los dos patrones de resolución anteriores en su caso, intente recopilar los siguientes registros de eventos de Windows:
- Registros de aplicaciones y servicios > Integration Runtime
- Aplicación de registros de > Windows
No se encuentra el botón Registrar para registrar un ir autohospedado
Síntomas
Al registrar una instancia de IR autohospedada, el botón Registrar no se muestra en el panel de Configuration Manager.
Causa
A partir de la versión de Integration Runtime 3.0, se ha quitado el botón Registrar en los nodos existentes de Integration Runtime para habilitar un entorno más limpio y seguro. Si un nodo se ha registrado en un entorno de ejecución de integración, esté en línea o no, vuelva a registrarlo en otro entorno de ejecución de integración desinstalando el nodo anterior y, a continuación, instale y registre el nodo.
Resolución
En Panel de control, desinstale el entorno de ejecución de integración existente.
Importante
En el proceso siguiente, seleccione Sí. No conserve los datos durante el proceso de desinstalación.
Si no tiene el archivo MSI del instalador del entorno de ejecución de integración, vaya al centro de descarga para descargar el entorno de ejecución de integración más reciente.
Instale el archivo MSI y registre el entorno de ejecución de integración.
No se puede registrar el entorno de ejecución de integración autohospedado debido a localhost
Síntomas
No se puede registrar el ir autohospedado en una máquina nueva cuando se usa get_LoopbackIpOrName.
Depuración: Se ha producido un error en tiempo de ejecución. El inicializador de tipo de "Microsoft.DataTransfer.DIAgentHost.DataSourceCache" produjo una excepción. Error no recuperable durante una búsqueda de base de datos.
Detalles de la excepción: System.TypeInitializationException: el inicializador de tipo de "Microsoft.DataTransfer.DIAgentHost.DataSourceCache" produjo una excepción. >--- System.Net.Sockets.SocketException: error no recuperable durante una búsqueda de base de datos en System.Net.Dns.GetAddrInfo(Nombre de cadena).
Causa
El problema suele producirse cuando se resuelve localhost.
Resolition
Use la dirección IP de localhost 127.0.0.1 para hospedar el archivo y resolver el problema.
Error en la instalación autohospedada
Síntomas
No puede desinstalar una instancia de IR existente, instalar una nueva instancia de IR o actualizar una instancia de IR existente a una nueva instancia de IR.
Causa
La instalación del entorno de ejecución de integración depende del servicio Windows Installer. Puede experimentar problemas de instalación por los siguientes motivos:
- Espacio en disco disponible insuficiente.
- Falta de permisos.
- El servicio Windows NT está bloqueado.
- El uso de CPU es demasiado alto.
- El archivo MSI se hospeda en una ubicación de red lenta.
- Algunos archivos o registros del sistema se tocaron involuntariamente.
La cuenta de servicio de IR no pudo capturar el acceso al certificado.
Síntomas
Al instalar una instancia de IR autohospedada a través de Microsoft Integration Runtime Configuration Manager, se genera un certificado con una entidad de certificación (CA) de confianza. No se pudo aplicar el certificado para cifrar la comunicación entre dos nodos y se muestra el siguiente mensaje de error:
"No se pudo cambiar el modo de cifrado de comunicación de intranet: no se pudo conceder a Integration Runtime cuenta de servicio el acceso al certificado "nombre> del certificado"<. Código de error 103"
Causa
El certificado usa el almacenamiento del proveedor de almacenamiento de claves (KSP), que aún no se admite. Hasta la fecha, IR autohospedado solo admite el almacenamiento del proveedor de servicios criptográficos (CSP).
Resolución
En este caso, se recomienda usar certificados CSP.
Solución 1
Para importar el certificado, ejecute el siguiente comando:
Certutil.exe -CSP "CSP or KSP" -ImportPFX FILENAME.pfx
Solución 2
Para convertir el certificado, ejecute los siguientes comandos:
openssl pkcs12 -in .\xxxx.pfx -out .\xxxx_new.pem -password pass: <EnterPassword>
openssl pkcs12 -export -in .\xxxx_new.pem -out xxxx_new.pfx
Antes y después de la conversión:
Versión 5.x de Integration Runtime autohospedado
Para la actualización a la versión 5.x del entorno de ejecución de integración autohospedado, se requiere .NET Framework Runtime 4.7.2 o posterior. En la página de descarga, encontrará vínculos de descarga para la versión 4.x más reciente y las dos últimas versiones de 5.x.
Para los clientes de Azure Data Factory v2 y Azure Synapse:
- Si la actualización automática está activada y ya ha actualizado el entorno de ejecución de .NET Framework a la versión 4.7.2 o posterior, el entorno de ejecución de integración autohospedado se actualizará automáticamente a la versión 5.x más reciente.
- Si la actualización automática está activada y no ha actualizado el entorno de ejecución de .NET Framework a la versión 4.7.2 o posterior, el entorno de ejecución de integración autohospedado no se actualizará automáticamente a la versión 5.x más reciente. El entorno de ejecución de integración autohospedado permanecerá en la versión 4.x actual. Puede ver una advertencia para una actualización de .NET Framework Runtime en el portal y el cliente de Integration Runtime autohospedado.
- Si la actualización automática está desactivada y ya ha actualizado el entorno de ejecución de .NET Framework a la versión 4.7.2 o posterior, puede descargar manualmente la versión 5.x más reciente e instalarla en el equipo.
- Si la actualización automática está desactivada y no ha actualizado el entorno de ejecución de .NET Framework a la versión 4.7.2 o posterior. Al intentar instalar manualmente integration runtime autohospedado 5.x y registrar la clave, primero deberá actualizar la versión de .NET Framework Runtime.
Para los clientes de Azure Data Factory v1:
- Integration Runtime autohospedado 5.X no admite Azure Data Factory v1.
- El entorno de ejecución de integración autohospedado se actualizará automáticamente a la versión más reciente de 4.x. Y la versión más reciente de 4.x no expirará.
- Si intenta instalar manualmente integration runtime autohospedado 5.x y registrar la clave, se le notificará que Integration Runtime autohospedado 5.x no admite Azure Data Factory v1.
Problemas de conectividad de IR autohospedado
El entorno de ejecución de integración autohospedado no se puede conectar al servicio en la nube
Síntomas
Al intentar registrar el entorno de ejecución de integración autohospedado, Configuration Manager muestra el siguiente mensaje de error:
"El nodo Integration Runtime (autohospedado) ha encontrado un error durante el registro".
Causa
El entorno de ejecución de integración autohospedado no se puede conectar al back-end del servicio. Este problema suele deberse a la configuración de red en el firewall.
Resolución
Compruebe si el servicio integration runtime se está ejecutando. Si es así, vaya al paso 2.
Si no hay ningún proxy configurado en el entorno de ejecución de integración autohospedado, que es la configuración predeterminada, ejecute el siguiente comando de PowerShell en la máquina donde está instalado el entorno de ejecución de integración autohospedado:
(New-Object System.Net.WebClient).DownloadString("https://wu2.frontend.clouddatahub.net/")
Nota:
La dirección URL del servicio puede variar, en función de la ubicación de la factoría de datos o de la instancia del área de trabajo de Synapse. Para buscar la dirección URL del servicio, use la página Administrar de la interfaz de usuario de la factoría de datos o Azure Synapse instancia para buscar entornos de ejecución de integración y haga clic en el ir autohospedado para editarlo. Seleccione la pestaña Nodos y haga clic en Ver direcciones URL del servicio.
La respuesta esperada es la siguiente:
Si no recibe la respuesta que esperaba, use uno de los métodos siguientes, según corresponda:
- Si recibe un mensaje "No se pudo resolver el nombre remoto", hay un problema del sistema de nombres de dominio (DNS). Póngase en contacto con el equipo de red para solucionar el problema.
- Si recibe un mensaje "ssl/tls cert is not trusted" (Certificado ssl/tls no es de confianza), compruebe el certificado (
https://wu2.frontend.clouddatahub.net/
) para ver si es de confianza en el equipo y, a continuación, instale el certificado público mediante el Administrador de certificados. Esta acción debe mitigar el problema. - Vaya al Visor de eventos de Windows>(registros)>Registros > de aplicaciones y serviciosIntegration Runtime y compruebe si hay algún error causado por DNS, una regla de firewall o la configuración de red de la empresa. Si encuentra un error de este tipo, cierre la conexión por la fuerza. Dado que cada empresa tiene su propia configuración de red personalizada, póngase en contacto con el equipo de red para solucionar estos problemas.
Si se ha configurado "proxy" en el entorno de ejecución de integración autohospedado, compruebe que el servidor proxy puede acceder al punto de conexión de servicio. Para obtener un comando de ejemplo, vea PowerShell, solicitudes web y servidores proxy.
$user = $env:username $webproxy = (get-itemproperty 'HKCU:\Software\Microsoft\Windows\CurrentVersion\Internet Settings').ProxyServer $pwd = Read-Host "Password?" -assecurestring $proxy = new-object System.Net.WebProxy $proxy.Address = $webproxy $account = new-object System.Net.NetworkCredential($user, [Runtime.InteropServices.Marshal]::PtrToStringAuto([Runtime.InteropServices.Marshal]::SecureStringToBSTR($pwd)), "") $proxy.credentials = $account $url = "https://wu2.frontend.clouddatahub.net/" $wc = new-object system.net.WebClient $wc.proxy = $proxy $webpage = $wc.DownloadData($url) $string = [System.Text.Encoding]::ASCII.GetString($webpage) $string
La respuesta esperada es la siguiente:
Nota:
Consideraciones de proxy:
- Compruebe si el servidor proxy debe colocarse en la lista Destinatarios seguros. Si es así, asegúrese de que estos dominios están en la lista Destinatarios seguros.
- Compruebe si el certificado SSL/TLS "wu2.frontend.clouddatahub.net/" es de confianza en el servidor proxy.
- Si usa la autenticación de Active Directory en el proxy, cambie la cuenta de servicio a la cuenta de usuario que pueda acceder al proxy como "servicio Integration Runtime".
No se pudo establecer una relación de confianza para el canal seguro SSL/TLS
Síntomas
El entorno de ejecución de integración autohospedado no se pudo conectar a Microsoft Purview.
Al comprobar el registro de eventos de IR autohospedado después de ir al Visor de eventos de Windows>(registros)>Registros de aplicaciones y servicios>Integration Runtime, encontrará el siguiente mensaje de error:
"Se cerró la conexión subyacente: no se pudo establecer una relación de confianza para el canal seguro SSL/TLS. El certificado remoto no es válido según el procedimiento de validación."
La manera más sencilla de comprobar el certificado de servidor del servicio es abrir la dirección URL del servicio en el explorador. Por ejemplo, abra el vínculo comprobar el certificado de servidor ((https://eu.frontend.clouddatahub.net/
) en la máquina donde está instalado el ir autohospedado y, a continuación, vea la información del certificado del servidor.
Causa
Hay dos razones posibles para este problema:
- Motivo 1: La entidad de certificación raíz del certificado de servidor del servicio no es de confianza en la máquina donde está instalada la instancia de IR autohospedada.
- Motivo 2: Está usando un proxy en el entorno, el certificado de servidor del servicio se reemplaza por el proxy y el certificado de servidor reemplazado no es de confianza para la máquina donde está instalado el ir autohospedado.
Resolución
- Por el motivo 1: asegúrese de que el certificado de servidor del servicio y su cadena de certificados son de confianza para la máquina donde está instalado el ir autohospedado.
- Por el motivo 2: confíe en la entidad de certificación raíz reemplazada en la máquina ir autohospedada o configure el proxy para que no reemplace el certificado de servidor del servicio.
Para obtener más información sobre cómo confiar en certificados en Windows, consulte Instalación del certificado raíz de confianza.
Más información
Hemos implementado un nuevo certificado SSL, que está firmado desde DigiCert. Compruebe si DigiCert Global Root G2 está en la CA raíz de confianza.
Si no está en la entidad de certificación raíz de confianza, descárguela aquí.
Pasos siguientes
Para obtener más ayuda con la solución de problemas, pruebe los siguientes recursos: