Los usuarios que usan Outlook para iOS y android y reglas de acceso a dispositivos (ABQ) se ponen en cuarentena inesperadamente
Número de KB original: 3193518
Síntomas
Exchange Online usuarios que usan Outlook para iOS y Android y que también usan reglas de acceso a dispositivos (ABQ) encuentran que se han puesto en cuarentena inesperadamente. Este problema se produce en el siguiente escenario:
- La propiedad del
DefaultAccessLevel
inquilino configurada a travésSet-ActiveSyncOrganizationSettings
de se establece en un valor de Cuarentena o Bloque. - El administrador de inquilinos permitió anteriormente Outlook para iOS y Android marcando DeviceID en la
ActiveSyncAllowedDeviceIDs
propiedad del buzón. - Los dispositivos no se administran mediante Microsoft Intune.
Causa
Un cambio de protocolo de back-end en la forma en que se accede a los datos de buzón de Microsoft 365 a través de outlook para aplicaciones iOS y Android cambia el DeviceID que la aplicación usa para conectarse a Exchange Online. El comportamiento esperado es que el nuevo DeviceID se agregará automáticamente al ActiveSyncAllowedDeviceID
para el usuario. Pero en determinados escenarios, el dispositivo puede estar en cuarentena. En tales casos, siga los pasos de la sección Resolución. No se espera que este problema se produzca repetidamente.
Solución
Póngase en contacto con el soporte técnico y pida al representante de servicio al cliente que le ayude a desbloquear el dispositivo.
O bien, use uno de los métodos siguientes para desbloquear el dispositivo:
Use el Centro de administración de Exchange para desbloquear dispositivos individuales. Para ello, siga estos pasos:
- Inicie sesión en Centro de administración de Exchange. Para obtener más información, consulte Centro de administración de Exchange en Exchange Online.
- Seleccione móvil y, a continuación, en Dispositivos en cuarentena, seleccione el botón Permitir para cada dispositivo de aplicación de Outlook para iOS y Android que necesite desbloquearse.
Use PowerShell remoto para desbloquear todos los dispositivos. Para ello, siga estos pasos:
Conéctese a Exchange Online mediante PowerShell remoto. Para obtener más información, vea Conexión a Exchange Online PowerShell.
Copie y pegue el código siguiente en la sesión remota de PowerShell:
function FixUnblock { $Mbxs = Get-CASMailbox -ResultSize 10000 | ?{$_.ActiveSyncAllowedDeviceIDs -ne $null } foreach($Mbx in $Mbxs) { write-host $Mbx.Id $IdList = Get-MobileDevice -Mailbox $Mbx.Id | where {$_.DeviceModel -eq "Outlook for iOS and Android" -and $_.ClientType -eq "REST" -and $_.DeviceAccessState -ne "Allowed" -and $_.FirstSyncTime -ge "9/13/2016"} $CasDevice = Get-CasMailbox $Mbx.Id foreach( $Id in $IdList) { $CasDevice.ActiveSyncAllowedDeviceIDs += $Id.DeviceId } Set-CasMailbox $Mbx.Id -ActiveSyncAllowedDeviceIDs $CasDevice.ActiveSyncAllowedDeviceIDs } }
En la sesión remota de PowerShell, ejecute la función . Para ello, escriba FixUnblock y presione Entrar.
Más información
Los usuarios con cuentas modernas habilitadas para la autenticación deben seguir los pasos descritos en Configuración de la cuenta con autenticación moderna en Exchange Online para configurar sus cuentas de Outlook para iOS y Android.
¿Aún necesita ayuda? Visite Comunidad Microsoft.