Los usuarios de carpetas públicas no pueden cambiar el nombre, mover ni eliminar subcarpetas
Síntomas
Después de que un usuario crea una subcarpeta en una carpeta pública, el usuario no puede cambiar el nombre, mover ni eliminar la subcarpeta.
Causa
La propiedad de buzón EffectivePublicFolderMailbox
de usuario no especifica el buzón de carpeta pública de la jerarquía principal para su organización de Microsoft Exchange.
Un algoritmo de Exchange que equilibra la carga de los usuarios en todos los buzones de carpeta pública asigna automáticamente un EffectivePublicFolderMailbox
valor a cada buzón de usuario.
Si el valor del buzón de usuario EffectivePublicFolderMailbox
especifica el buzón de carpeta pública de la jerarquía principal para la organización de Exchange, el usuario tiene el permiso Propietario en subcarpetas de carpetas públicas que crea dentro de cualquier buzón de carpeta pública. El permiso Propietario permite a los usuarios cambiar el nombre, mover y eliminar esas subcarpetas.
Si el valor del buzón de usuario EffectivePublicFolderMailbox
especifica un buzón de carpeta pública de jerarquía secundaria, el usuario hereda los permisos de carpeta primaria en las subcarpetas de carpetas públicas que crea en cualquier buzón de carpeta pública. El problema que se describe en la sección "Síntomas" se produce si el usuario tiene uno de los siguientes permisos de carpeta pública en la carpeta primaria:
PublishingEditor: conjunto de permisos basado en roles que incluye el permiso CreateSubfolders
PublishingAuthor: conjunto de permisos basado en roles que incluye el permiso CreateSubfolders
CreateSubfolders: necesario para crear una subcarpeta
Solución alternativa
Para solucionar el problema, conceda al usuario el permiso Propietario en subcarpetas que cree o tenga que administrar. Use uno de los métodos siguientes.
Nota:
Para usar los métodos siguientes, debe tener permisos de administrador.
Método 1: Uso del Centro de administración de Exchange
En el Centro de administración de Exchange (EAC), vaya a Carpetas>públicas Carpetas públicas.
Vaya a la subcarpeta del usuario y seleccione Administrar en el panel derecho.
Conceda al usuario el permiso Propietario en la subcarpeta.
Nota:
En función de la ubicación de la carpeta pública y del entorno de Exchange, use Exchange Online o EAC local.
Método 2: Uso del cliente de escritorio de Outlook
En el cliente de escritorio de Microsoft Outlook, vaya a la subcarpeta del usuario y abra la ventana Propiedades .
En la pestaña Permisos , seleccione el nivel de permiso Propietario y, a continuación, seleccione Agregar para especificar el usuario.
Método 3: Uso de PowerShell
Ejecute el cmdlet Add-PublicFolderClientPermission para conceder al usuario el permiso Propietario en una subcarpeta:
Add-PublicFolderClientPermission -Identity <subfolder ID> -User <user ID> -AccessRights Owner
Nota:
Según la ubicación de la carpeta pública y el entorno de Exchange, es posible que primero tenga que conectar la sesión de PowerShell a Exchange Online. Para las carpetas públicas locales, use el Shell de administración de Exchange (EMS).
Más información
Para determinar los permisos de usuario para una carpeta o subcarpeta pública, compruebe EAC o ejecute el siguiente comando:
Get-PublicFolderClientPermission <folder ID> | FT FolderName,User,AccessRights
Para determinar el valor de propiedad
EffectivePublicFolderMailbox
de un buzón de usuario, ejecute el siguiente comando:Get-Mailbox -Identity <user mailbox> | FL Name,EffectivePublicFolderMailbox
Para identificar el buzón de carpetas públicas de la jerarquía principal de la organización de Exchange, compruebe el EAC o ejecute el siguiente comando:
Get-Mailbox -PublicFolder | FT Name,IsRootPublicFolderMailbox