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Conflicto de direcciones de proxy al agregar una dirección de correo electrónico en Exchange Online

Síntomas

Al intentar asignar una dirección de proxy a un destinatario de correo nuevo o existente en Exchange Online, recibirá un mensaje de error similar a uno de los ejemplos siguientes.

Error 1

La dirección proxy "SMTP:<conflicting SMTP address>" ya está siendo usada por "<domain.prod.outlook.com/Microsoft> Exchange Hosted Organizations/contoso.onmicrosoft.com/<forest>". Elija otra dirección de proxy.

Error 2

Se realizó una llamada de id. de Microsoft Entra para mantener el objeto sincronizado entre microsoft Entra ID y Exchange Online. Sin embargo, se produjo un error. Mensaje de error detallado: ya existe otro objeto con el mismo valor para proxyAddresses de propiedad. ConflictingObject: PublicFolder_<GUID>.

Algunos ejemplos de destinatarios de correo incluyen un usuario de correo, un buzón de usuario, un buzón compartido, un grupo de distribución, un grupo de Microsoft 365 y una carpeta pública habilitada para correo (MEPF).

Causa

Causa 1

El primer mensaje de error se produce si un objeto habilitado para correo en Exchange Online usa la dirección de proxy que desea asignar.

Causa 2

El segundo mensaje de error se produce si un objeto MEPF que solo existe en el id. de Microsoft Entra usa la dirección de proxy que desea asignar.

Solución

La resolución del primer error es buscar y quitar cualquier dirección de proxy en conflicto en Exchange Online.

La resolución del segundo error es buscar y quitar cualquier dirección de proxy en conflicto en Exchange Online y para comprobar y quitar cualquier dirección de proxy en conflicto en el identificador de Entra de Microsoft.

Use la resolución adecuada, en función del mensaje de error que reciba. A continuación, intente volver a asignar la dirección de proxy.

Buscar y quitar cualquier dirección de proxy en conflicto en Exchange Online

Siga estos pasos para buscar objetos habilitados para correo existentes en Exchange Online que usan la dirección de proxy en conflicto.

  1. Conectarse a PowerShell de Exchange Online.

  2. Para enumerar todos los destinatarios de correo que usan la dirección SMTP en conflicto, ejecute el siguiente comando:

    Get-EXORecipient -ResultSize unlimited | Where-Object {$_.EmailAddresses -match "<conflicting SMTP address>"} | fl Name, RecipientType, EmailAddresses
    

    Si no conoce la dirección SMTP exacta, ejecute el siguiente comando en su lugar:

    Get-EXORecipient -ResultSize unlimited | Where-Object {$_.EmailAddresses -match "<partial conflicting SMTP address>"} | fl Name, RecipientType, EmailAddresses
    
  3. Una dirección de proxy solo se puede asignar a un objeto a la vez. Después de determinar qué objeto está en conflicto, quite o cambie la dirección de proxy asociada a ese objeto.

    Por ejemplo, si el objeto es una carpeta pública habilitada para correo, ejecute el siguiente comando para deshabilitar la carpeta pública para liberar la dirección de correo electrónico que se usa:

    Get-MailPublicFolder -ResultSize Unlimited | Where-Object {$_.EmailAddresses -match "<conflicting SMTP address>"} | Disable-MailPublicFolder
    

Buscar y quitar cualquier dirección de proxy en conflicto en el identificador de Entra de Microsoft

Importante

Esta resolución requiere un servidor local con Microsoft Entra Connect instalado. Si se retira la infraestructura local, póngase en contacto con Soporte técnico de Microsoft.

Siga estos pasos para comprobar y quitar de Microsoft Entra cualquier MEPF que usen la dirección de proxy en conflicto. Estos pasos requieren un servidor local que ejecute Microsoft Entra Connect versión 2.0 o una versión posterior.

  1. Para buscar la dirección de proxy en conflicto en todos los MEPF locales, ejecute el siguiente comando en el Shell de administración de Exchange (EMS) local:

    Get-MailPublicFolder -ResultSize Unlimited | Where-Object {$_.EmailAddresses -match "<conflicting SMTP address>"}
    
  2. Para cada MEPF local que se identifica en el paso 1, quite la dirección SMTP en conflicto ejecutando el siguiente comando en el EMS local:

    Set-MailPublicFolder -Identity <public folder name or GUID> -EmailAddresses @{remove="<conflicting SMTP address>"} -EmailAddressPolicyEnabled:$false
    

    En este paso se quitan los conflictos de direcciones de proxy en el lado local para asegurarse de que no están sincronizados con el identificador de Microsoft Entra o Exchange Online.

  3. Si quitó una dirección SMTP en conflicto de cualquier MEPF local en el paso 2, espere hasta que se ejecute la siguiente sincronización programada en el servidor Microsoft Entra Connect o inicie manualmente un ciclo de sincronización ejecutando el siguiente comando de PowerShell:

    Start-ADSyncSyncCycle -PolicyType Delta
    

    La sincronización debe quitar la dirección SMTP en conflicto de Microsoft Entra ID.

  4. Si no encontró la dirección SMTP en conflicto en ningún MEPF local o si la sincronización no quitó la dirección SMTP en conflicto de Microsoft Entra ID, busque id. de Entra de Microsoft para los MEPF que tengan la dirección SMTP en conflicto. Para buscar MEPF en microsoft Entra ID, use el cmdlet Get-ADSyncToolsAadObject de PowerShell en el servidor microsoft Entra Connect. La búsqueda no distingue entre mayúsculas y minúsculas. Incluya el prefijo "smtp:" al especificar la dirección SMTP.

    $mailEnabledPublicFolders = Get-ADSyncToolsAadObject -SyncObjectType "PublicFolder" -Credential (Get-Credential)
    
    $conflictingSmtpAddress = "smtp:<conflicting SMTP address>"
    
    $mailEnabledPublicFolders | Where-Object {$_.ProxyAddresses -icontains $conflictingSmtpAddress} | Select SourceAnchor
    

    Los resultados de la búsqueda proporcionan SourceAnchor para cada MEPF que cumpla los criterios de búsqueda.

  5. Para cada MEPF identificado en el paso 4, quite el MEPF de Microsoft Entra ID mediante el cmdlet Remove-ADSyncToolsAadObject . Proporcione el SourceAnchor valor del MEPF en formato Base64.

    $conflictingSourceAnchor= "SourceAnchor value"
    
    Remove-ADSyncToolsAadObject -SourceAnchor $conflictingSourceAnchor -SyncObjectType "PublicFolder" -Credentials (Get-Credential)
    

    Para obtener un ejemplo de uso de cmdlets, consulte el ejemplo 2 de Remove-ADSyncToolsAadObject.

  6. Vuelva a ejecutar la búsqueda del id. de Entra de Microsoft en el paso 4. Esta vez, los resultados de la búsqueda no deben devolver ningún MEPF.