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No se puede abrir OWA, ECP o EMS después de quitar un certificado autofirmado del sitio web del back-end de Exchange

Número de KB original: 2779694

Síntomas

Tenga en cuenta el siguiente escenario cuando use Microsoft Exchange Server 2013 o Exchange Server 2016:

  • El certificado de microsoft Exchange Self-Signed se quita del sitio web de back-end de Exchange mediante mmc de certificados, Remove-Exchangecertificateadministrador de IIS u otro método.
  • Para borrar la memoria caché de IIS, reinicie o IISReset.

En este escenario, no se pueden conectar varios protocolos de cliente, como Exchange Panel de control (ECP), Outlook Web App (OWA), Exchange ActiveSync y Shell de administración de Exchange (EMS). Pueden producirse los siguientes problemas:

  • OWA y ECP muestran una página en blanco.

  • Exchange ActiveSync los usuarios no pueden recibir correos electrónicos.

  • EMS no se puede conectar y muestra el siguiente error:

    New-PSSession : [xy.local.contoso.com] Processing data from remote server xy.local.contoso.com failed with the
    following error message: The WinRM Shell client cannot process the request. The shell handle passed to the WSMan Shell
    function is not valid. The shell handle is valid only when WSManCreateShell function completes successfully. Change
    the request including a valid shell handle and try again. For more information, see the about_Remote_Troubleshooting
    Help topic.
    At line:1 char:1
    + New-PSSession -ConnectionURI "$connectionUri" -ConfigurationName Microsoft.Excha ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [New-PSSession], PSRemotin
       gTransportException
        + FullyQualifiedErrorId : -2144108212,PSSessionOpenFailed
    Failed to connect to an Exchange server in the current site.
    Enter the server FQDN where you want to connect.:
    

Causa

Durante el proceso de instalación, un certificado autofirmado denominado Microsoft Exchange está enlazado al sitio web de back-end de Exchange en el puerto 444. El certificado es para la comunicación entre el sitio web predeterminado y los sitios web back-end de Exchange. Cuando se quita el certificado, el sitio web predeterminado no puede establecer conexiones proxy con el sitio web back-end de Exchange.

Solución

Para resolver este problema, vuelva a agregar el certificado al sitio web de back-end de Exchange mediante la creación de un nuevo certificado autofirmado y, a continuación, enlazarlo al sitio web del back-end de Exchange.

Nota:

Estos pasos deben realizarse en el rol de servidor buzón de Exchange.

  1. Inicie el Shell de administración en el servidor de buzones de correo.
  2. Escriba New-ExchangeCertificate.

    Nota:

    Si se le pide que sobrescriba el certificado predeterminado, seleccione No.

  3. Inicie el Administrador de IIS en el servidor de buzones de correo.
  4. Expanda Sitio, resalte Back-End de Exchange y seleccione Enlaces en el panel Acciones de la columna del lado derecho.
  5. Seleccione Tipohttps en el puerto 444.
  6. Seleccione Editar y seleccione el certificado de Microsoft Exchange.
  7. Desde un símbolo del sistema del administrador, ejecute IISReset.