Compartir a través de


Solución de problemas de adaptadores de línea de negocio distintos de WCF

Error al recuperar

Si se usa un adaptador de línea de negocio (LOB) distinto de WCF, se pueden producir los errores siguientes:

  • Error al recuperar el sistema

  • Agente de exploración: error atrapado en el constructor. El equipo de destino rechazó la conexión.

  • Agente en tiempo de ejecución: error atrapado en el constructor. El equipo de destino rechazó la conexión.

Causa

Los adaptadores de LOB usan las características remotas de .Net. Si la activación de las características remotas de .Net tarda más de lo previsto, puede que el adaptador devuelva estos errores.

Resolución

Cree la clave del Registro StartAgentSleep y aumente el valor de tiempo de espera:

  1. Abra el Registro y vaya a HKEY_LOCAL_MACHINE\software\Microsoft\BizTalkAdapters.

  2. Cree un valor de DWORD nuevo con las propiedades siguientes:

    Nombre: StartAgentSleep

    Base: Decimal

    Datos de valor: 1000

    El valor de datos se mide en milisegundos (ms). 1000 ms equivalen a 1 segundo.

    En algunos sistemas, puede que un segundo no sea suficiente. Aumente el valor y haga pruebas para determinar el tiempo de espera necesario.

Importante

Agregar la clave del Registro StartAgentSleep afecta a todos los adaptadores de LOB que no son WCF.

Consulte también

Solucionar problemas de adaptadores de BizTalk Server