Compartir a través de


Solución de problemas de reparación de mensajes y nuevo envío

No se puede enviar un mensaje reparado si no se implementa el esquema de sobre

Síntoma

Cuando intenta enviar un mensaje que ha reparado, A4SWIFT publica el mensaje siguiente:

"El adaptador no pudo transmitir el mensaje que va a enviar el puerto http://mrsrtest:80/StsWebReceive/default.aspx?PartnerId=Unparsed&FolderType=MessagesInbox. Se retransmitirá después del intervalo de reintento especificado para este puerto de envío. Details:"80131600". Para obtener más información, consulte El Centro de ayuda y soporte técnico en https://go.microsoft.com/fwlink/?LinkId=142493.

Causa posible

El esquema de sobre no se implementa. Esto es cierto para cualquier mensaje MTxxx o cualquier mensaje que haya producido un error al analizar.

Solución

Implemente un esquema de sobre para cada esquema de mensaje que esté usando (<unidad:\Archivos de programa>\Microsoft BizTalk Accelerator for SWIFT <version> Message Pack \SWIFT Messages\ A4SWIFT-SRG version\Category n\MTxxx.xsd) y para el esquema de sobres sin análisis (<unidad>:\Archivos de programa\Microsoft BizTalk Accelerator for SWIFT version> \SWIFT <Messages\ A4SWIFT-SRG<<version>>\ Unparsed Message\EnvelopeUnparsedMessage.xsd). Para obtener más información, consulte Implementación de esquemas de A4SWIFT.

No se puede enviar un mensaje no corregido desde una biblioteca de sitios MRSR denominada distinta de "Sinparsed"

Síntoma

Al intentar enviar un mensaje sin análisis que ha corregido desde una biblioteca de documentos del sitio MRSR que no se denomina "Sin análisis", se produce un error en la operación.

Causa posible

A4SWIFT no puede enviar correctamente un mensaje de una biblioteca que no se denomina "Sinparsed". Si tiene una biblioteca de documentos "Sinparsed" existente en el sitio MRSR antes de instalar la característica MRSR (reparación de mensajes), A4SWIFT configuración creará una biblioteca para los mensajes no analizadores titulados "Unparsed" con un sufijo. Cuando recibe un mensaje que A4SWIFT no se pudo analizar, enrutará el mensaje a esa biblioteca que creó. Sin embargo, al intentar enviar un mensaje desde esa biblioteca, se producirá un error en la operación.

Solución

Quite la característica MRSR, elimine la biblioteca Sinparsed y vuelva a instalar la característica MRSR.

No se puede devolver un mensaje en un flujo de trabajo de dos fases

Síntoma

Si rechaza un mensaje en la fase reparación de un flujo de trabajo que solo tiene una fase Crear y una fase de reparación, se produce un error en el envío. BizTalk Server enruta el mensaje de nuevo al cuadro de mensajes y publica el siguiente mensaje de error:

"No se pudo restablecer a la primera fase del flujo de trabajo".

Causa posible

El bucle invertido de mensajes no es compatible con un flujo de trabajo que solo tiene una fase De creación y una fase de reparación.

Solución

Agregue otra fase al flujo de trabajo de dos fases o cancele el envío.

No se puede abrir un mensaje en la bandeja de entrada de reparación en MRSR

Síntoma

Al intentar abrir un mensaje en la bandeja de entrada de reparación en MRSR, recibirá el siguiente mensaje de error en un elemento emergente:

"No se puede abrir la base de datos solicitada en el inicio de sesión "A4SWIFT". Error de inicio de sesión. Error de inicio de sesión del usuario "NT AUTHORITY\NETWORK SERVICE".

Causa posible

La cuenta de inicio de sesión de la aplicación web en la que se ejecuta el servicio web A4SWIFT_MRSR es Servicio de red, no una cuenta de dominio o local que se encuentra en el grupo usuarios de A4SWIFT.

Solución

Cambie la cuenta de inicio de sesión de la aplicación web en la que se ejecuta el servicio web A4SWIFT_MRSR.

Para cambiar la cuenta de inicio de sesión de la aplicación web en la que se ejecuta el servicio web de A4SWIFT_MRSR
  1. Haz clic en Inicio, apunta a Todos los programas, Herramientas administrativas y haz clic en Administrador de Internet Information Services (IIS).

  2. En el Administrador de IIS, expanda el nodo nombre> del< servidor (equipo local), el nodo Grupos de aplicaciones y el nodo Sitios web. En el nodo Sitios web, expanda el nodo Sitio web predeterminado .

  3. En el nodo Sitio web predeterminado, haga clic con el botón derecho en A4SWIFT_MRSR y, a continuación, haga clic en Propiedades.

  4. En el cuadro de diálogo Propiedades de A4SWIFT_MRSR, anote el grupo de aplicaciones.

  5. En el cuadro de diálogo Administrador de IIS, en el nodo Grupos de aplicaciones, haga clic con el botón derecho en el grupo de aplicaciones para A4SWIFT_MRSR y, a continuación, haga clic en Propiedades.

  6. En el cuadro de diálogo Propiedades del nombre> del <grupo de aplicaciones, haga clic en la nota Identidad. Si se hace clic en Predefinido y se selecciona Servicio de red , haga clic en Configurable, escriba su cuenta de dominio o local y, a continuación, escriba la contraseña. Haga clic en OK.

No se procesa un mensaje creado en el sitio MRSR en un equipo localizado

Síntoma

Cuando un usuario que trabaja en una versión en inglés de A4SWIFT que se ejecuta en una plataforma localizada crea un mensaje en un formulario de InfoPath en MRSR y envía el mensaje correctamente, el mensaje parece ser consumido por la reparación de mensajes y la nueva orquestación de envío, pero no se procesa correctamente. El mensaje se envía a la bandeja de salida, pero el adaptador de BizTalk no lo recoge. No se publica ningún error o advertencia en el Visor de eventos y no hay ningún registro de una instancia de orquestación en ejecución en HAT.

Causa posible

Ruta de acceso especificada como el URI del STS. La ubicación de recepción de la bandeja de salida contiene el nombre en inglés, no el nombre localizado.

Solución

Cambie la dirección URI del STS. Ubicación de recepción de la bandeja de salida de la siguiente manera:

  1. En la consola de administración de BizTalk Server 2009, expanda los nodos Grupo de BizTalk, Aplicaciones y Aplicación de BizTalk 1.

  2. Haga clic en Ubicaciones de recepción.

  3. Haga doble clic en Sts.Outbox.Location.

  4. En el cuadro de diálogo Propiedades de ubicación de recepción, haga clic en Configurar.

  5. En el cuadro de diálogo Propiedades de transporte, reemplace el valor de Dirección URL de SharePointSite por el equivalente localizado.

  6. Haga clic en Aceptar y, a continuación, vuelva a hacer clic en Aceptar.

Quitar un rol mientras procesa un mensaje da como resultado la eliminación incompleta de documentos y artefactos

Síntoma

Cuando se quita un rol en el cliente web de perfil, se publica un cuadro de diálogo que indica que se quitarán todos los documentos y artefactos asociados al rol. Sin embargo, el rol no se quita del departamento en la consola de administración de A4SWIFT y las carpetas de documentos del rol (bandeja de entrada y elementos enviados) no se quitan de MRSR. La entidad, el puerto de envío y el acuerdo asociados al rol se quitan y el perfil del rol no se implementa.

Causa posible

Un mensaje todavía está en la bandeja de entrada del rol en MRSR y el mensaje está abierto en su formulario de InfoPath.

Solución

Elimine manualmente el mensaje de la bandeja de entrada del sitio MRSR y, a continuación, elimine la biblioteca de documentos asociada al rol que estaba quitando. Cierre el formulario y vuelva a quitar el rol.

Se produce un error en el procesamiento de mensajes como resultado de un error en la directiva maestra BIC.

Síntoma

Al enviar un mensaje para su procesamiento, recibirá el siguiente error:

"Error al ejecutar BicMasterPolicy. Compruebe la directiva para ver los valores válidos".

Causa posible

El nombre de SQL Server, el nombre de la base de datos BIC y el valor de seguridad integrado en el archivo BIC_Master_Policy.xml en <unidad>:\Archivos de programa\ Acelerador de Microsoft BizTalk para el paquete de mensajes de la versión> SWIFT\SWIFT <Messages\A4SWIFT-SRG<version>\Base Policies se incluyen entre comillas dobles. Para habilitar la validación BIC, escriba estas cadenas en el archivo BIC_Master_Policy.xml predeterminado, tal y como se describe en Habilitación de la validación de códigos de identificador bancario.

Solución

Para reparar la directiva maestra BIC, continúe de la siguiente manera:

Nota

Para obtener más información sobre cómo implementar la directiva maestra BIC, consulte Implementación de reglas BRE.

  1. En Business Rule Composer, anulación de la implementación de la versión 1.0 del BIC_Master_Policy y, a continuación, elimine el BIC_Master_Policy.

  2. En un editor de texto, como el Bloc de notas, abra BIC_Master_Policy.xml en <unidad:\Archivos de programa>\ Acelerador de Microsoft BizTalk para paquete de mensajes de versión> SWIFT\MENSAJES SWIFT<\A4SWIFT-SRG<version>\Base Policies. Quite las comillas dobles alrededor del nombre SQL Server, el nombre de la base de datos BIC y el valor de seguridad integrado.

  3. En el Asistente para la implementación del motor de reglas de negocios, importe BIC_Master_Policy.xml y, a continuación, implemente BIC_Master_Policy.xml.

  4. En mmC de servicios, reinicie el servicio de actualización del motor de reglas y el servicio host de recepción de BizTalk.

A4SWIFT no podrá procesar un mensaje sin análisis sin permisos de base de datos adecuados.

Síntoma

Cuando se quita un mensaje que A4SWIFT no se puede analizar, A4SWIFT no puede procesar el mensaje, pero se produce un error con una excepción no detectada.

Causa posible

Hay un problema de permisos de base de datos. La cuenta de inicio de sesión para el servicio de BizTalk, que de forma predeterminada es HostSvc, no se incluye en los grupos administradores de A4SWIFT y A4SWIFT usuarios.

Solución

Agregue la cuenta de inicio de sesión del servicio de BizTalk a los grupos administradores de A4SWIFT y usuarios de A4SWIFT.

Un tiempo de espera del formulario de reparación de InfoPath puede dar lugar a dos copias de un mensaje en distintas fases del flujo de trabajo de reparación.

Síntoma

Al enviar un mensaje desde un formulario de InfoPath (para cualquier fase de flujo de trabajo), si se produce un error en el envío del formulario, el error podría dar lugar a dos copias del mensaje. Un mensaje todavía está en la bandeja de entrada para las fases actuales y el otro mensaje está en la bandeja de entrada para el siguiente rol del flujo de trabajo. Si intenta procesar estos mensajes, se producirá lo siguiente:

  • Si envía el mensaje desde la bandeja de entrada para el siguiente rol del flujo de trabajo, el mensaje continuará a través del flujo de trabajo.

  • Si envía el mensaje desde la bandeja de entrada para la fase actual después de que el mensaje enviado desde la bandeja de entrada de la siguiente fase haya completado el procesamiento, el mensaje enviado desde la bandeja de entrada actual se suspenderá con un error de enrutamiento.

  • Si envía el mensaje en la bandeja de entrada para la fase actual antes de que el mensaje enviado desde la bandeja de entrada de la siguiente fase haya completado el procesamiento, el mensaje enviado desde la bandeja de entrada de la fase actual se devolverá a la bandeja de entrada para esa fase y recibirá el siguiente error: "Restablecer flujo de trabajo debido a: el mensaje se ha alterado o el usuario no es válido para esta fase". Después de esto, si envía el mensaje desde la bandeja de entrada para la siguiente fase, también se restablecerá el flujo de trabajo para él. Se devolverá a la bandeja de entrada de la fase actual y recibirá el error anterior.

Causa posible

El formulario de InfoPath ha enviado el mensaje a BizTalk Server a través de Microsoft Windows Sharepoint Services y un servicio web personalizado que realiza validaciones. El envío de un mensaje se realiza en varios pasos y estos pasos no son transaccionales, ya que Windows Sharepoint Services no es transaccional. Para dar cabida a esta limitación, las orquestaciones MRSR han integrado la lógica de recuperación para detectar y recuperarse de errores derivados del envío de mensajes. Las orquestaciones MRSR siempre impiden que los mensajes duplicados se envíen a SWIFT.

Solución

Si esto ocurre, debe elegir el mensaje que va más allá en el flujo de trabajo y completar su flujo de trabajo antes de intentar procesar los demás mensajes que se encuentran en las fases anteriores del flujo de trabajo. Una vez que el mensaje que se encuentra más a lo largo del flujo de trabajo ha completado el procesamiento, puede eliminar el segundo mensaje (que se suspendió con un error de enrutamiento) como considere oportuno.

Si el mensaje que está más a lo largo del flujo de trabajo no completó el procesamiento antes de procesar el segundo mensaje, debe volver a reparar el mensaje que está más a lo largo del flujo de trabajo en el formulario de reparación de InfoPath y, a continuación, enviarlo. Permita que complete el procesamiento y envíe el segundo mensaje. Una vez suspendido el segundo mensaje, desechelo.

Un nuevo envío sin fase de comprobación dará lugar a un mensaje suspendido

Síntoma

Cuando se envía un nuevo mensaje en un flujo de trabajo que no tiene ninguna fase de comprobación, el mensaje se suspende.

Causa posible

La falta de una fase de comprobación da como resultado un mensaje suspendido si A4SWIFT_MRSRLastStage no está establecido en Crear.

Solución

Use una suscripción de A4SWIFT_MRSRLastStage == Crear para asegurarse de que el mensaje se enruta correctamente.

La validación del mensaje da como resultado un "error de análisis" en el panel de tareas del formulario de InfoPath

Síntoma

El botón Validar mensaje en el panel de tareas del formulario de InfoPath muestra "analizar el error" sin ninguna descripción.

Solución

Reinicie el servicio web MRSR o realice iisreset.

La publicación de un formulario de InfoPath genera un error de autorización

Síntoma

La publicación de un formulario de InfoPath produce un error de autorización.

Solución

Reemplace el nombre del equipo por localhost en la dirección URL del sitio MRSR.

El panel de tareas del formulario de InfoPath muestra el código fuente HTML

Síntoma

El panel de tareas del formulario de InfoPath muestra el código fuente HTML en lugar de los controles web.

Solución

Vaya a Lapestaña Herramientas-Seguridad> ->Zona internet y habilite Abrir archivo basado en contenido que no esté en la extensión en Varios.

El sitio web del cliente web de perfil genera un error de autenticación

Síntoma

El sitio web del cliente web de perfil muestra el error de autenticación.

Solución

Ejecute BTSharePointAdapterWSAppPool y DefaultAppPoolApplication> y el grupo en Internet Information Services(IIS) en la cuenta de administrador.

Consulte también

Solución de problemas: problemas y soluciones