Solución de problemas de instalación y configuración
El programa de instalación no puede implementar el ensamblado RuntimeSchemas
Síntoma
El programa de instalación de A4SWIFT no pudo implementar RuntimeSchemas.dll. Si el ensamblado no se implementa manualmente después de la instalación, se produce un error en el Asistente para configuración de A4SWIFT.
Causa posible
Existe una de las siguientes condiciones:
El ensamblado Esquemas en tiempo de ejecución ya se implementó cuando intentó realizar una instalación inicial de A4SWIFT.
Microsoft SQL Server no se inició en el equipo en el que intentó instalar A4SWIFT.
El ensamblado Esquemas en tiempo de ejecución ya se implementó cuando intentó actualizar A4SWIFT y otro ensamblado hizo referencia a él. Esto impidió la implementación del ensamblado de esquemas en tiempo de ejecución por parte del programa de actualización de A4SWIFT.
Solución
Continúe de la siguiente manera, dependiendo de la naturaleza del problema:
Si el ensamblado Esquemas en tiempo de ejecución ya se implementó al intentar ejecutar una instalación inicial de A4SWIFT, abra el Explorador de BizTalk en Microsoft Visual Studio.NET, haga clic con el botón derecho en el ensamblado Microsoft . Solutions.FinancialServices.SWIFT.RuntimeSchemas y, a continuación, haga clic en Anular implementación. Use el Asistente para la implementación de BizTalk para implementar la versión más reciente de RuntimeSchemas.dll desde %programfiles%\Microsoft BizTalk Accelerator para SWIFT\Assemblies.
Si no se inició SQL Server, inicie SQL Server en el SQL Server Service Manager. Use el Asistente para la implementación de BizTalk para implementar la versión más reciente de RuntimeSchemas.dll desde %programfiles%\Microsoft BizTalk Accelerator para SWIFT\Assemblies.
Si el ensamblado De esquemas en tiempo de ejecución ya se implementó cuando intentó actualizar A4SWIFT y otro ensamblado hizo referencia a él, anula la implementación del ensamblado de referencia en el Explorador de BizTalk y anula la implementación de RuntimeSchemas.dll en el Explorador de BizTalk. Use el Asistente para la implementación de BizTalk para implementar la versión más reciente de RuntimeSchemas.dll desde %programfiles%\Microsoft BizTalk Accelerator para SWIFT\Assemblies.
Después de quitar la característica Componentes web, la reparación de mensajes y la conciliación se muestran incorrectamente como desinstaladas.
Síntoma
Después de quitar la característica Componentes web para reparación de mensajes y nuevo envío de A4SWIFT, no puede desinstalar, instalar ni configurar la característica reparación y conciliación de mensajes (o A4SWIFT componentes). Si se instala la reparación y conciliación de mensajes, A4SWIFT no reconoce que la característica está instalada. Si intenta instalar, modificar o quitar reparación y conciliación de mensajes desde Agregar o quitar programas (mostrados desde Panel de control), Agregar o quitar programas indicará que la característica no está instalada.
Causa posible
Se le quitó del grupo administradores de BizTalk Server después de haber instalado la característica Componentes web para reparación de mensajes y nuevo envío y la característica Reparación y conciliación de mensajes. Si después quita la característica Componentes web (que puede hacer sin ser miembro del grupo administradores de BizTalk Server), el programa de instalación de A4SWIFT quitará los archivos en los que la característica Reparación y conciliación de mensajes tiene una dependencia. Estos archivos incluyen ConfigFramework.exe.
Solución
Si encuentra este problema, continúe de la siguiente manera:
En la ventana Administración de equipos, vuelva a agregarse al grupo administrador de BizTalk Server, cierre la sesión del equipo y vuelva a iniciar sesión.
Vuelva a instalar los componentes web para la reparación de mensajes y la nueva característica de envío.
Nota
El paso 2 vuelve a agregar ConfigFramework.exe a la instalación de A4SWIFT.
Vuelva a instalar la característica MRSR.
Si sigue sin querer la característica Componentes web para reparación de mensajes y nuevo envío, quítela.
La reparación de A4SWIFT para agregar la carpeta Servicio puede dar lugar a permisos de acceso incorrectos para esa carpeta.
Síntoma
Si elimina la carpeta %programfiles%\Microsoft BizTalk Accelerator for SWIFT\Service de una instalación de A4SWIFT configurada correctamente y, a continuación, ejecuta la característica reparación de A4SWIFT programa de instalación para agregar la carpeta Servidor de nuevo en la instalación de A4SWIFT, los permisos de acceso de la carpeta Servicio no serán correctos. Los permisos correctos son Control total para administradores de A4SWIFT y Leer & Ejecutar para A4SWIFT Usuarios.
Esto también ocurre si ejecuta la característica reparación de A4SWIFT configuración cuando existe la carpeta Servicio. Los permisos de acceso, establecidos por el Asistente para configuración de A4SWIFT, se sobrescribirán con valores incorrectos.
Causa posible
La instalación de los componentes web para la reparación de mensajes y la característica Nuevo envío agrega la carpeta Servicio. Si elimina la carpeta y, a continuación, ejecuta la opción Reparar de A4SWIFT programa de instalación para agregar los componentes web para reparación de mensajes y nuevo envío, A4SWIFT programa de instalación no ejecuta el Asistente para configuración (ConfigFramework.exe) para establecer los permisos de la carpeta. Dado que el asistente para configuración ya se ha ejecutado, es muy difícil volver a ejecutar el asistente para restablecer la configuración. Como resultado, la opción Reparar volverá a crear todos los archivos y carpetas eliminados, pero no establecerá los permisos de acceso correctamente.
El proceso de reparación también sobrescribe los permisos de la carpeta Servicio si la carpeta existe cuando se ejecuta la reparación. Al igual que sucede con el caso de eliminar la carpeta Servicio antes de ejecutar la reparación, será muy difícil ejecutar el programa de configuración para establecer los permisos. En este caso, también, los permisos serán incorrectos y tendrá que establecerlos manualmente.
Solución
Si se produce este problema, establezca manualmente los siguientes permisos de acceso para la carpeta Servicio:
Nombre de usuario o grupo | Permiso |
---|---|
administradores de A4SWIFT | Control total |
usuarios de A4SWIFT | Leer y ejecutar |
Para establecer estos permisos, siga estos pasos:
En el Explorador de Windows, vaya a %programfiles%\Microsoft BizTalk Accelerator for SWIFT\Service.
Haga clic con el botón derecho en la carpeta Servicio, haga clic en Propiedadesy, a continuación, haga clic en la pestaña Seguridad .
En el panel Nombres de grupo o usuario del cuadro de diálogo Propiedades del servicio, haga clic en Agregar, escriba <el nombre> del servidor\A4SWIFT Administradores y, a continuación, haga clic en Aceptar.
Nota:
Si el grupo administradores de A4SWIFT es un grupo de dominio, escriba <nombre> de dominio\A4SWIFT Administradores.
Repita el paso 2 para <nombre> de servidor\A4SWIFT Usuarios o <nombre> de dominio\A4SWIFT Usuarios si el grupo Usuarios de A4SWIFT es un grupo de dominio.
En el panel Nombres de grupo o usuario, seleccione A4SWIFT Administradores. En el panel Permisos, seleccione Permitirel control total.
En el panel Nombres de grupo o usuario, seleccione A4SWIFT Usuarios. En el panel Permisos, haga clic en Permitir lectura & Ejecutar, Enumerar contenido de la carpeta y Leer.
Haga clic en OK.
La actualización da como resultado una instalación en paralelo de dos versiones de A4SWIFT
Síntoma
Al intentar actualizar a A4SWIFT, es posible que las versiones anteriores de A4SWIFT no se quiten completamente. Si ejecuta Agregar o quitar programas de la Panel de control, la lista de Programas instalados actualmente podría mostrar el actual y las versiones anteriores.
Causa posible
Cualquiera de las condiciones siguientes puede hacer que se produzca lo anterior:
El usuario que intenta actualizar no es miembro del grupo administradores de BizTalk Server.
El servicio SQL Server (MSSQLSERVER) se detiene.
Ha realizado una actualización silenciosa mediante el comando setup.exe /addlocal .
Solución
Para evitar una instalación en paralelo de A4SWIFT 2.1 y A4SWIFT 3.0 durante la actualización, asegúrese de que (el usuario que ha iniciado sesión) sea miembro del grupo administradores de BizTalk Server y de que se inicie el servicio SQL Server (MSSQLSERVER).
Si termina con una instalación en paralelo de A4SWIFT 2.1 o A4SWIFT 2.3 y A4SWIFT 3.0, siga estos pasos:
Realice una copia de seguridad de los datos en la carpeta Mensajes de SWIFT.
Inicie sesión en el BizTalk Server como miembro del grupo Administradores de BTS y asegúrese de que el servicio MSSQLSERVER se esté ejecutando.
Quite la versión anterior de A4SWIFT.
Vuelva a actualizar a la versión más reciente de A4SWIFT. Esta vez funcionará la actualización y no se creará ninguna instalación en paralelo.
Con la Utilidad de implementación de BizTalk, anulación manual de la implementación de Microsoft .Solutions.FinancialServices.SWIFT.RuntimeSchemas.dll y, a continuación, vuelva a implementarla desde la carpeta Ensamblados de la ubicación de instalación de A4SWIFT. Para obtener más información sobre esta herramienta, consulte Utilidad de implementación de BRE.
Es posible que el proceso de desinstalación o actualización no se complete correctamente si no se reinicia cuando se le solicita
Síntoma
Los procesos de desinstalación o actualización no se completan correctamente.
Causa posible
Si no ha implementado un proyecto que hace referencia a un ensamblado implementado existente, puede recibir un mensaje que indique que debe reiniciar el sistema para que los cambios de configuración de A4SWIFT surtan efecto. Si no hace clic en Sí para reiniciar inmediatamente, es posible que algunos ensamblados asignados para su eliminación en la caché global de ensamblados no se quiten, lo que hace que los procesos de desinstalación o actualización adicionales no se completen correctamente.
Solución
Anula la implementación de cualquier proyecto que haga referencia a un ensamblado implementado existente y, a continuación, vuelva a ejecutar el proceso de desinstalación o actualización.
Si el servicio de Administración IIS se detiene durante la instalación, debe volver a configurar la característica WebService.
Síntoma
El Asistente para configuración de A4SWIFT no configura correctamente la característica WebService. Recibe el siguiente error:
"No se pueden crear artefactos MRSR: no se puede conectar al servidor remoto".
Causa posible
El servicio Administración IIS se detuvo cuando ejecutó el Asistente para configuración de A4SWIFT.
Solución
Para completar correctamente el proceso de configuración, continúe de la siguiente manera:
Cierre la consola de configuración de A4SWIFT.
Reinicie el servicio de Administración IIS.
Ejecute %programfiles%\Microsoft BizTalk Accelerator para SWIFT\Configuration.exe.
En la consola de configuración de A4SWIFT, seleccione Desconfigurar características y, a continuación, seleccione WebService.
Asegúrese de que el estado de la característica WebService en la consola de configuración se muestra como no configurado.
Seleccione Aplicar configuración.
Nota
El Asistente para configuración de A4SWIFT ahora configurará correctamente la característica WebService.
A4SWIFT configuración producirá un error si el host de BizTalkServerApplication no se creó en BizTalk Server configuración
Síntoma
El Asistente para configuración de A4SWIFT no configura correctamente la característica WebService. Recibe el siguiente error:
"No se pueden crear artefactos MRSR: referencia de objeto no establecida en una instancia de un objeto".
Causa posible
No se creó un host de In-Process y una instancia de host durante BizTalk Server configuración en tiempo de ejecución.
Solución
Para reparar la configuración de A4SWIFT, continúe de la siguiente manera:
Cree un host en administración de BizTalk Server. No es necesario tener una instancia en ejecución ahora.
Ejecute la herramienta RepairBAS en la carpeta %programfiles%\Microsoft BizTalk Accelerator for SWIFT\SDK\Tools de la instalación de A4SWIFT.
Para ello, continúe de la siguiente manera:
Inicie BizTalk Server consola de administración.
En la consola de administración de BizTalk Server, expanda BizTalk Server Administración, expanda Grupo de BizTalk y, a continuación, expanda Configuración de la plataforma.
Haga clic con el botón derecho en Hosts, seleccione Nuevoy, a continuación, seleccione Host.
En la pantalla Propiedades del host, en el panel General, escriba lo siguiente:
Nombre de host: BizTalkServerApplication
Tipo: En proceso
Grupo de Windows: <domain>\BizTalk Application Users (o la cuenta que configuró durante BizTalk Server configuración para ejecutar aplicaciones de BizTalk In-Process)
En la sección Opciones, seleccione Allow Host Tracking (Permitir seguimiento de host ) y Make this the default host in the group (Permitir el seguimiento de host) y Make this the default host in the group (Permitir el seguimiento de host) y Make this the default host in the group (Permitir el seguimiento de host
Haga clic en OK.
Haga clic en Inicio y, a continuación, haga clic en Ejecutar. Escriba cmd y, a continuación, haga clic en Aceptar.
En el símbolo del sistema, vaya a %programfiles%\Microsoft BizTalk Accelerator for SWIFT\SDK\Tools.
Escriba RepairBAS.exe y presione Entrar.
Debe cambiar el archivo de configuración de implementación de BRE al ejecutar la utilidad de implementación de BRE en un equipo de 64 bits.
Síntoma
La utilidad de implementación de BRE no funciona correctamente cuando se ejecuta en un equipo de 64 bits o en un directorio no predeterminado (distinto de C:\Archivos de programa\Acelerador de Microsoft BizTalk para SWIFT) en un equipo de 32 bits.
Causa posible
La Utilidad de implementación de BRE no funcionará correctamente hasta que cambie las rutas de acceso en el archivo BREDeployment.exe.config ubicado en la <unidad>:\Archivos de programa\Microsoft BizTalk Accelerator for SWIFT\SDK\Tools carpeta.
Solución
Actualice la configuración de la utilidad abriendo BREDeployment.exe.config en el Bloc de notas y cambiando las carpetas de las directivas base, esquemas y directorios de vocabulario.