Solución de problemas de compresión de archivos de Azure Content Delivery Network
Importante
Azure CDN Estándar de Microsoft (clásico) se retirará el 30 de septiembre de 2027. Para evitar cualquier interrupción del servicio, es importante que migrar los perfiles de Azure CDN Estándar de Microsoft (clásico) al nivel Estándar o Premium de Azure Front Door hasta el 30 de septiembre de 2027. Para más información, consulte Retirada de Azure CDN Estándar de Microsoft (clásico).
Azure CDN de Edgio se retiró el 15 de enero de 2025. Para más información, consulte Preguntas frecuentes sobre retirada de Azure CDN de Edgio.
Este artículo le ayudará a solucionar los problemas con la compresión de archivos de red CDN.
Si necesita más ayuda en cualquier momento con este artículo, puede ponerse en contacto con los expertos de Azure en los foros de MSDN Azure y de desbordamiento de pila. Como alternativa, también puede registrar un incidente de soporte técnico de Azure. Vaya al sitio de soporte técnico de Azure y seleccione Soporte técnico.
Síntoma
Está habilitada la compresión para el punto de conexión, pero se devuelven archivos sin comprimir.
Sugerencia
Para comprobar si los archivos se devuelven comprimidos, debe usar una herramienta como Fiddler o las herramientas de desarrollo del explorador. Compruebe los encabezados de respuesta HTTP devueltos con el contenido de la red de entrega de contenido almacenado en caché. Si hay un encabezado denominado Content-Encoding
con un valor de gzip, bzip2, brotli o deflate, el contenido se comprime.
Causa
Hay varias causas posibles, por nombrar algunas:
- El contenido solicitado no es apto para la compresión.
- La compresión no está habilitada para el tipo de archivo solicitado.
- La solicitud HTTP no incluía un encabezado que solicitara un tipo de compresión válido.
- El origen está enviando contenido fragmentado.
Pasos para solucionar problemas
Sugerencia
Al igual que con la implementación de nuevos puntos de conexión, los cambios de configuración de la red de entrega de contenido tardan algún tiempo en propagarse a través de la red. Normalmente, los cambios se aplican en un plazo de 90 minutos. Si esta es la primera vez que configura la compresión para su punto de conexión de la red de entrega de contenido, debe considerar una espera de 1 o 2 horas para asegurarse de que la configuración de la compresión se propagó a los POP.
Comprobar la solicitud
En primer lugar, se debe hacer una comprobación rápida en la solicitud. Puede usar las herramientas de desarrollo del explorador para ver las solicitudes que se realizan.
- Compruebe que la solicitud se envía a la dirección URL del punto de conexión,
<endpointname>.azureedge.net
, y no a su origen. - Compruebe que la solicitud contenga un encabezado Accept-Encoding y que el valor para el encabezado contenga gzip, deflate, brotli o bzip2.
Comprobación de la configuración de compresión
Desplácese hasta el punto de conexión en Azure Portal y seleccione el botón Configurar.
- Compruebe que la compresión está habilitada.
- Compruebe que el tipo MIME del contenido que se va a comprimir se incluya en la lista de formatos comprimidos.
Compruebe la solicitud en el servidor de origen para un encabezado Mediante
El encabezado Mediante HTTP indica al servidor web que un servidor proxy pasará la solicitud. De forma predeterminada, los servidores web de Microsoft IIS no comprimen las respuestas si la solicitud contiene un encabezado Mediante. Para anular este comportamiento, haga lo siguiente: