Opalis Integration Server Log Purge times out or returns an exception
Symptoms
When using the Opalis Integration Server "Log Purge" functionality either scheduled or directly from the Opalis Integration Server Client via the "Purge Now..." button, the purge operation either times out and does not complete or returns an exception.
Cause
The Log Purge functionality has a hard coded timeout value to complete the execution of the SQL queries that are being called. If this timeout period expires, then the log purging operation does not complete successfully.
Resolution
Log Purge functionality has three options:
- Keep last x number of records
- Keep last y number of days.
- If records are older than y number of days, keep last x number of records.
These three options dictate how the stored procedure “sp_CustomLogCleanup” is called. To call the stored procedure in a manner that mimics the Log Purge functionality (but without the hardcoded timeout) you can execute one of the following three scripts in SQL Management Studio where @XEntries is the number of entries to keep and @YDays is the number of days to either keep entries or the number of days to determine when entries should be processed:
Option #1
DECLARE @Completed bit
SET @Completed = 0
WHILE @Completed = 0 EXEC sp_CustomLogCleanup @Completed OUTPUT, @FilterType=1,@XEntries=1000
Option #2
DECLARE @Completed bit
SET @Completed = 0
WHILE @Completed = 0 EXEC sp_CustomLogCleanup @Completed OUTPUT, @FilterType=2,@YDays=7
Option #3
DECLARE @Completed bit
SET @Completed = 0
WHILE @Completed = 0 EXEC sp_CustomLogCleanup @Completed OUTPUT, @FilterType=3,@XEntries=1000,@YDays=7
For more information and all the details of this issue see the following new Knowledge Base article:
KB2290555 - Opalis Integration Server Log Purge times out or returns an exception
J.C. Hornbeck | System Center Knowledge Engineer
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