Some columns don't contain data in a model-driven app
This article provides troubleshooting steps for an issue where some columns don't contain data in a model-driven app in Microsoft Power Apps.
Symptoms
You might find data isn't displayed in certain columns in a Power Apps model-driven app.
Cause
This issue is often caused by the discrepancies between the fetchXML request (the query for data) and the layoutXML (the column definitions), which might be due to custom code that incorrectly modifies the query. Before troubleshooting the issue, follow the steps described in Steps to perform before starting troubleshooting.
Troubleshooting step
First, you should ensure the issue isn't related to insufficient permissions. The easiest way to check this is to navigate to the page as a user with full administrative privileges. The Power Apps Monitor tool can also be used to ensure the column data is readable.
If the issue isn't related to insufficient permissions, use the Power Apps Monitor tool to check the query and columns definition as shown in the following screenshot.
Make sure that all the columns listed in the viewFields
section are present in the viewFetchXML
query and that the respective columns aren't marked as hidden
.
The issue can also be caused by a corrupt view. Resaving and republishing such a view might help solve the problem.