"ServiceUnavailable (409) - requested resource is not available in the location" error
This article discusses how to resolve the ServiceUnavailable (409) error ("The requested resource is not available in the location" '<region-name>' at this moment") that occurs when you try to deploy a resource in Microsoft Azure Container Instances.
Symptoms
You receive an error message that resembles the following text:
The requested resource is not available in the location 'usgovvirginia' at this moment. Please retry with a different resource request or in another location. Resource requested: '2' CPU '4' GB memory 'Linux' OS virtual network. ServiceUnavailable (409).
Cause
This issue might occur if a feature isn't available in certain regions or if there's a lack of capacity. This issue is typically intermittent.
Solution
To determine whether you can deploy to an available region, see Resource availability & quota limits for Azure Container Instances.
To determine which features are available in your region, use the Location - List Capabilities REST API. You can also verify available features per region by selecting the "Try it" button in that article.
If you're deploying in an available region, and there's no feature limitation, retry the deployment.
Contact us for help
If you have questions or need help, create a support request, or ask Azure community support. You can also submit product feedback to Azure feedback community.