New Teams desktop app fails to render video
Symptoms
You're using the new Microsoft Teams desktop app on a computer that also has the Nahimic audio driver installed. During a Teams meeting, the app does not render video in any of the following scenarios:
- Video content is presented during the meeting.
- You join a meeting without having video enabled, and then you enable video while you're in the meeting.
- Before you join a meeting, you check the video preview screen in the meeting join window to verify that the video works correctly.
Cause
This issue occurs because of a conflict that exists between the new Teams app and the Nahimic audio driver.
Workaround
To work around the issue, follow these steps:
Exit the Teams desktop app.
Search in File Explorer for a file named BlackApps.dat in the %PROGRAMDATA% folder. This file is the exclusion list used by the Nahimic app.
Open the BlackApps.dat file by using a text editor, such as Notepad.
Note: If you can't open the file, follow these steps to change permissions on the file:
- Right-click the file, and then select Properties.
- Select the Security tab, and then select the Edit button.
- On the Permissions screen, in the Group or user names box, select the appropriate group to which you belong.
- In the list in the Permissions box, select Allow for the Full control permission.
- Select Apply, and then select OK to close the Permissions screen.
- Close the Properties dialog box.
In the BlackApps.dat file, add the following executable files:
ms-teams.exe
msedgewebview2.exe
Save the file, and then exit the text editor.
Restart the Teams desktop app.
Third-party information disclaimer
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.