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FIM Troubleshooting: Failed to retrieve schema or cannot connect to database while creating a FIM MA

PROBLEM STATEMENT

You recently installed FIM 2010 Update 2 (4.00.3606.2) with a SQL Server 2008 R2 backend.  Everything seems good.  You then attempt to create a FIM Service Management Agent.  You receive an error message “Failed to retrieve schema” or “Cannot connect to Database”.

CAUSE

The cause of this issue is that the .NET Framework v4.0 is not installed on the FIM Synchronization Service. 

RESOLUTION

In this case, there are two possible solutions for this problem.

.NET Framework

  •  Install the Microsoft .NET Framework v4.0

MIIServer.exe.config

  1. On the FIM Synchronization Service Machine, Stop the FIM Synchronization Service
  2. Navigate to %programfiles%\Microsoft Forefront Identity Manager\2010\Synchronization Service\Bin
  3. Edit the miiserver.exe.config file
  4. In the <startup> section, swap the order of the supportedRuntime

FROM

  <startup useLegacyV2RuntimeActivationPolicy="true">

    <supportedRuntime version="v4.0.30319"></supportedRuntime>

    <supportedRuntime version="v2.0.50727"></supportedRuntime>

  </startup>

TO

  <startup useLegacyV2RuntimeActivationPolicy="true">

    <supportedRuntime version="v2.0.50727"></supportedRuntime>

    <supportedRuntime version="v4.0.30319"></supportedRuntime>

  </startup>

  1. Save the miiserver.exe.config file
  2. Start the FIM Synchronization Service
  3. Create the FIM Service Management Agent 

SEE ALSO