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SCOM 2007 Troubleshooting: Total CPU Utilization Percentage is too high

Summary

The CPU Utilization (Processor\ Processor Time\Total and System Queue Length) for the system processor(s) has exceeded the threshold. Once exceeded overall system performance may diminish significantly which will result in poor operating system and application performance.

Configuration

The Total CPU Utilization monitoring routine is a high configurable solution that enables Operators to set threshold values for both the System\Processor Queue and the Processor\ Processor Time\Total performance counters. When values for both counters have exceeded the defined thresholds for several consecutive samples a state change will occur for the monitor. The number of consecutive samples that must be sampled above the threshold before changing state is also configurable.

The default threshold values for the Total CPU Utilization monitoring routine monitoring routine include:

Parameter   Default Value  
CPUQueueLengthThreshold 15
CPUPercentageThreshold 95
NumSamples 5

Please note that Overrides can be used to change any of the threshold values that are defined above.

Causes

When a computer is under substantial load for a sustained period of time it can be caused by any of the following conditions:

1 The resource requirements for the application set installed on the computer exceeds the capabilities of the computer’s hardware configuration.
2 Demand on the computer resources has increased over time and the computer hardware configuration is no longer able to satisfy increasing demand.
3 An application that is running on the computer may have entered into an unhealthy state and is now demanding irregular volumes of system resources.

Resolution

To view recent history for the Processor related performance counters you can use the following view:

Start Processor Performance View

To resolve this issue an administrator can perform the following tasks:

  1. Evaluate the % Processor Utilization counter for each of the processes running on the server. This can be done by using either Task Manager or the Performance Monitoring snap-in. Determine which process(s) are consuming the most resources and monitor them over time to determine whether they appear to be returning to normal performance ranges. If not, addition application specific diagnostics should be performed to determine the most appropriate way to resolve the issue.
  2. If it is determined that client load has increased over time and the computer is simply no longer able to satisfy demand, perform additional performance monitoring procedures to determine if basic hardware upgrades can enable the computer to return to optimal performance ranges.
  3. If it has been determined that the application has entered into an unhealthy state, possibly due to a product defect, it might be necessary to restart the application. If the issue persists, you might need to contact the application vendor.