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Troubleshooting: Limited External Calling in Lync Client

Overview

We have the following scenario:
All servers are installed with Windows Server 2008 R2 Service Pack 1. Lync Standard Server was configured with sip home.com.br domain and Active Directory domain is named fqdn home.intranet

http://3.bp.blogspot.com/-CDX8ZYslWEY/TynFpp8sQLI/AAAAAAAAC7Q/ch2c18S9wwo/s640/topologia.jpg 

Installing and configuring Edge Pool was conducted in accordance with the article: Instalação do Lync Edge Server em DMZ Double Hop (pt-BR) 

Symptom

After publishing the Edge Server in the structure Lync customers exhibit the error
 

Calling External Limit

http://1.bp.blogspot.com/-EPjNy591cEw/TzhKCfoByKI/AAAAAAAADJ0/ZPLmWFcRlws/s320/clErr01.png 

The following message is displayed by clicking the error

http://2.bp.blogspot.com/-bRpzJ6WXGtU/TzhKDEw2BYI/AAAAAAAADJ8/Yg4fQ8ufNS8/s320/clErr02.png 

Some calls to and from people outside of your corporate network may not connect due to server connectivity problems. Try singing out and singing back in. If this problem continues, please contact your support team. 

Cause

This error occurs when traffic MRAS is not permitted from the Front End server into the Edge Server internal network card.
Enabling logging on the Lync client can see the error line

http://4.bp.blogspot.com/-e_trCDfgrRQ/TzhMkCNbHMI/AAAAAAAADKc/biLIobcK2rY/s400/clErr06.png 

And the log of the firewall that separates the Front End Server and Edge Server can see the connection fails

http://1.bp.blogspot.com/-UQzgZD2A7Nk/TzhKDqhjypI/AAAAAAAADKE/3ktEzQvEeyI/s320/clErr03.png 

Solution

To solve this problem, create a firewall rule allowing the connection on port 5062/TCP originating from the Front End Server and Edge Server destination.
In this environment, we created a protocol in TMG 2010

MRAS Authentication

Port: 5062

Protocol: TCP

Direction: Inbound

http://3.bp.blogspot.com/-O5R8f1BZcgQ/TyWxs0U1y_I/AAAAAAAAC1k/bwz5FmCc4mE/s320/edge08.png 

And created an access rule between server roles

http://4.bp.blogspot.com/-VN7o60K0n4A/TzhPHh9rhII/AAAAAAAADKk/EY1-IN42WB0/s640/clErr07.png 

With the rule created in the user log out Lync client and log in again. The error should disappear.

http://1.bp.blogspot.com/-4muW8P0iAUY/TzhKEzseipI/AAAAAAAADKU/mbPM85TIscM/s320/clErr05.png 

And the firewall log should show a successful connection to the configured port.

http://3.bp.blogspot.com/-28c2AqZW434/TzhKEVQIZEI/AAAAAAAADKM/3HrcLbTe4vg/s320/clErr04.png 


 

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