Replica inconsistent and insufficient disk space on BMR (Bare Metal Recovery) Backup (How To Fix)
System Center Data Protection Manager 2010 (DPM 2010) offers with its new console in the creation of a protection group in System Protection, a new option called "Bare Metal Recovery".
This option saves the operating system files (System State) and critical volumes (excluding user data) to restore it very quickly to new hardware. This feature existed in DPM 2007 with Software Removal Tool.
The problem is that sometimes the BMR backup "Bare Metal Recovery" is not working properly and fails with the message "Replica inconsistent" caused by "insufficient disk space".
Cause:
DPM 2010 does not calculate the size of BMR data source, but assumes 30 GB for all servers. Admins should change the value as per the size of BMR backups expected on their environments.
The size of BMR backup is approximately equal to the amount of space used on all critical volumes.
Critical volumes = Boot Volume + System Volume + Volume hosting system state data such as AD DIT/log volumes.
Solution:
We need to run the BMR backup Manually (without DPM) to know the disk size needed on DPM:
- Create a shared folder with enough space to store the BMR backup, for example \ \ server_name \ BMR
- On the production server, launch the command prompt with administrative privileges
- Then type the following command:
wbadmin.exe start backup -allcritical -quiet -backuptarget:\\server_name\bmrshare
- Once the backup is complete, check the disk space consumed by the BMR backup and make sure that the same amount of disk space or more have been allocated to the replica volume.
- Also increase the disk space of volume recovery point.
- Then in the DPM console, starts the consistency check on our replica inconsistent
Once these operations are completed the BMR backup will be created and recovery points are available.
External Link :
http://technet.microsoft.com/en-us/library/ff634208.aspx