MIM 2016 Troubleshooting: no-start-bad-ma-configuration
Applies to
- Microsoft Identity Manager 4.3.1935.0
- other versions not reported
Issue
When you're trying to make a full import on the fim service MA you get the error no-start-bad-ma-configuration.
Error message
Application - Error ID 6311
Log Name: Application
Source: FIMSynchronizationService
Date: dd/mm/yyyy hh:MM:ss AM
Event ID: 6311
Task Category: Server
Level: Error
Keywords: Classic
User: N/A
Computer: server.customer.domain.com
Description:
The server encountered an unexpected error while performing a callback operation.
"BAIL: MMS(8548): manhost.cpp(1010): 0x80230709 (The extension operation aborted due to an internal error in FIM Synchronization Service.)
BAIL: MMS(8548): nathost.cpp(657): 0x80231319 (Encountered exception when querying objects from the application store.)
WARNING: MMS(8548): ..\cntrler.cpp(3130): MA ecode 80231319 different from sync 0 ecode
BAIL: MMS(8548): ..\cntrler.cpp(3163): 0x80231319 (Encountered exception when querying objects from the application store.)
BAIL: MMS(8548): ..\cdext.cpp(416): 0x80070057 (The parameter is incorrect.)
BAIL: MMS(8548): ..\xstack.cpp(405): 0x80070057 (The parameter is incorrect.)
BAIL: MMS(8548): ..\xparse.cpp(436): 0x80070057 (The parameter is incorrect.)
BAIL: MMS(8548): ..\ScriptManagerImpl.cpp(9205): 0x80070776 (The object exporter specified was not found.)
BAIL: MMS(8548): ..\mastate.cpp(6551): 0x80070776 (The object exporter specified was not found.)
BAIL: MMS(8548): ..\ma.cpp(670): 0x80070776 (The object exporter specified was not found.)
BAIL: MMS(8548): ..\ma.cpp(1120): 0x80070776 (The object exporter specified was not found.)
Forefront Identity Manager 4.3.1935.0"
Application - Error ID 6500
Log Name: Application
Source: FIMSynchronizationService
Date: dd/mm/yyyy hh:MM:ss AM
Event ID: 6500
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: server.customer.domain.com
Description:
An error occurred in executing a delta import.
Type: Microsoft.ResourceManagement.IdentityManagementException
Details: Delta Import cannot be run as the change log has been detected to be in a corrupted state.
Stack Trace: at MIIS.ManagementAgent.Import.DeltaImportSession.ReadNextBatch()
at MIIS.ManagementAgent.Import.DeltaImportSession.GetNextBatch()
Root cause
These errors are based on Workflow load on the SQL server and waiting for a long time getting results from Stored Procedures in that situation.
Troubleshooting
Update MA config
Open Properties for the MA and walk through each configuration page of the properties dialog, re-enter the password and save the MA, with that, we re-write the XML definition and the MA in the database.
That hopefully could correct the MA already. If you then run Import, check if it fails again.
Refresh schema
In the MIM Synchronization Manager GUI, right-click the MA properties and refresh the schema.
Solution
We have two sides from where we can start working on that situation: MIM side and SQL side.
In MIM setup using 4.3.1935.0 we miss some functionality which was added in later builds to tweak request handling and some performance improvements added in later builds.
MIM
So from MIM point of view, we currently have no option except upgrading to MIM 2016 SP1 and current rollup package (4.4.1749.0)
SQL
From SQL side we have these options:
- Database maintenance
- More SQL resources to the MIM instance
- Dedicated SQL server just for MIM,
- PSSDiag on your SQL server
Database maintenance
Performing database maintenance on the FIMService database and test again when that has completed:
- Rebuild indices
- Update statistics
- Rebuild ftcatalog
More SQL Resources
Check with the SQL team if they can offer more resources to the MIM instance or maybe move other databases, services to other SQL servers\instances to get your instance faster (most often disk io is the major bottleneck in MIM deployments, not CPU or RAM)
Dedicated SQL
You could test using a dedicated SQL server just for MIM, it would at least proof that this is really dependent on SQL performance
SQL Performance analysis
If you need some proof or more details on SQL load, performance etc., you can involve our MS SQL Support team and run a PSSDiag on your SQL server when you run the Full Import and reproduce that error; maybe we can see more hints from that report.