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Exchange Server Troubleshooting: Unable to upgrade with error code '3221684229'

Symptom

Unable to upgrade the exchange server to CU14. [ERROR] An error occurred with error code '3221684229' and message 'Access is denied.'

Assessment

  1. Download procmon tool
  2. Capture the procmon during the setup failure
  3. Export the capture as CSV
  4. Filter the CSV result field with access denied

Cause

Check if below events regarding access denied are logged in proc Mon capture

*"19:29.1 ExSetupUI.exe 30216 CreateFile \Device\HarddiskVolumeShadowCopy9\System Volume Information ACCESS DENIED Desired Access: Read Data/List Directory, Synchronize, Disposition: Open, Options: Directory, Synchronous IO Non-Alert, Attributes: n/a, ShareMode: Read, Write, Delete, AllocationSize: n/a"
*

Resolution

Identify if the above volume listed is shadowcopyvolume or disk volume

If its shadowcopy volume, delete the shadow using the command

DISKSHADOW>delete shadows all

If its Disk volume, identify the volume using below command

DISKPART> list volume Provide the account used for installation full control over the system volume folder on volume listed

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