MIM 2016 Troubleshooting: FIM MA Full import error 0x80070002
Symptoms
When you try to run an Full import run profile on the MIMMA, you get an error message in the MIM GUI.
On Screen
Unable to run the management agent.
The system cannot find the file specified. (Exception from HRESULT: 0x80070002)
Error Message
Log Name: Application Source: FIMSynchronizationService Date: 10/17/2016 5:38:58 PM Event ID: 6309 Task Category: Server Level: Error Keywords: Classic User: N/A Computer: SERVER.SUBDOMAIN.AD.ACCEPT.ROOT Description: The server encountered an unexpected error while performing an operation for a management agent. "BAIL: MMS(39888): ..\ma.cpp(3781): 0x80070002 (The system cannot find the file specified.) Forefront Identity Manager 4.3.1935.0" Event Xml: <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event"> <System> <Provider Name="FIMSynchronizationService" /> <EventID Qualifiers="49152">6309</EventID> <Level>2</Level> <Task>3</Task> <Keywords>0x80000000000000</Keywords> <TimeCreated SystemTime="2016-10-17T15:38:58.000000000Z" /> <EventRecordID>409902</EventRecordID> <Channel>Application</Channel> <Computer>SERVER.SUBDOMAIN.AD.ACCEPT.ROOT</Computer> <Security /> </System> <EventData> <Data>BAIL: MMS(39888): ..\ma.cpp(3781): 0x80070002 (The system cannot find the file specified.) Forefront Identity Manager 4.3.1935.0</Data> </EventData> </Event>
Other Symptoms
When you try to stop the run of the MIM MA you get an error.
Root Cause
The option "run the management agent in a separate process" is activated.
Explanation
This is by design, as this option is deprecated and should not be used.
Resolution
Uncheck the option "Run this management agent in a separate process" from the "Configure extensions" item in the management agent properties.