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BizTalk Server Troubleshooting: "Failed to update binding information" - Object reference not set to an instance of an object.

Issue

This article explains how to resolve the issue causing BizTalk Server Administration Console to fail importing bindings to a BizTalk Integration.

Sometimes this error will occur when importing existing bindings to an application in BTS Admin Console. It may be the case that you have just exported the bindings, deleted the application and recreated it, then attempted to import the bindings and encountered the error.

Here is what it looks like:

Cause

This issue is caused by the application not having the same references it had when the bindings were exported. On the scenario above, you may have recreated the BizTalk Application, but haven't added the references to other applications it needs. 

Solution

Right click on the Application you are trying to import the bindings into and add references to other Applications as needed.

Conclusion

We hope this article helps you move along these simple but sometimes terrifying errors.

See Also

Another important place to find a huge amount of BizTalk related articles is the TechNet Wiki itself. The best entry point is BizTalk Server Resources on the TechNet Wiki