BizTalk Accelerator for HL7: Resolving Event 8706, Unable to log message.
Issue
This article explains how to resolve the issue causing Event ID 8607 for BizTalk Accelerator for HL7: Unable to log message "A message was received of type http..." to the event log due to exception: "No connection could be made because the target machine actively refused it 127.0.0.1:4000".
Cause
This issue is caused by the HL7 Logging Windows Service being stopped.
Solution
Under Windows Services, locate "HL7 Logging Service" and enable it. It is also a good idea to make sure it is set to start automatically.
Conclusion
We hope this article helps resolve this sometimes puzzling BizTalk HL7 error.
See Also
Also it is important to not the change in the behavior of the logging service in the Biztalk 2013 onwards as it is not present as a windows service and the logging has been moved to the BTAHL7 database. The KB for this can be found at kb3002939
Another important place to find a huge amount of BizTalk related articles is the TechNet Wiki itself. The best entry point is BizTalk Server Resources on the TechNet Wiki.