RDP Troubleshooting: IaaS VM restore using Azure backup
Symptoms:
Post restore operation triggered from Azure backup for an IaaS VM, I am not able to RDP into the VM.
Possible Causes:
Post restore, VHDs are appended with meta data and this meta data causes network issues.
Solution:
Please check if VM is running. If VM is running, clear the meta data from VHD blob.
To clear meta data:
- Download “Azure Storage Explorer 4.0” from http://azurestorageexplorer.codeplex.com/releases/view/54430
- Click on Add Account and input storage account name and key. To get storage account key, go to management portal and select storage account and click on "Manage Keys".
- Double click on the blob corresponding to VHDs, select the metadata tab, delete the metadata and Save.