AD CS Troubleshooting: CA installation error "Provider could not perform the action since the context was acquired as silent. 0x80090022 (-2146893790)"
Symptom
Certificate Authority installation fails:
"Provider could not perform the action since the context was acquired as silent. 0x80090022 (-2146893790)"
Cause
Check the CA registry for the following value:
Key Name:
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Cryptography
Class Name: <NO CLASS>
Last Write Time: 3/18/2011 - 5:27 AM
Value 0
Name: forcekeyprotection
Type: REG_DWORD
Data: 0x2
This registry value likely comes from the following Group Policy or local policy setting:
Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options\
System cryptography: Force strong key protection for user keys stored on the computer
Resolution
This value should not be set on a Microsoft CA since, by default, administrator intervention when accessing the CA's private key is disabled.
You should either edit Group Policy, local policy, or the registry so that this value is not set on the CA.