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FIM Reporting Troubleshooting: A Transport-Level Error Has Occurred During Initial Sync

Issue

 During an initial sync of FIM Reporting ​(start-FIMReportingInitialSync.ps1), we see a SQL timeout error in the Reporting Job Status.

Reporting Job Details: A transport-level error has occurred when receiving results from the server. (provider: TCP Provider, error: 0 - The semaphore timeout period has expired.)

https://microsoft.sharepoint.com/teams/iamsupport/iamblog/SiteAssets/reporting_initial_1.png 

TROUBLESHOOTING

The cause was due to a SQL contention issue that can arise if FIM Synchronizations are running during the initial Reporting sync. 

See FIM 2010 R2 Reporting Troubleshooting Doc for more details: http://technet.microsoft.com/en-us/library/jj133862%28v=ws.10%29.aspx 

Incremental / Initial sync job shows a timeout exception error

Cause

Contention on the Management Server database caused by pruning and grooming jobs running at the same time as the sync job. Most often caused by failing to deploy, or mis-deploying, the Data Warehouse Support Scripts.

Solution

Re-run incremental or initial synchronization.

Additional Notes

To ensure this does not happen in the future, you may also wish to suggest that users ensure that no synchronization jobs are running at the same time as the SCSM Management Server pruning and grooming jobs

These pruning and grooming jobs run every day starting at 0:00.

You can change the reporting job schedule by going to the FIM SQL Agent Job scheduler and modifying the FIM_ScheduleReportingIncrementalSync job schedule.

RESOLUTION

Turn FIM Synchronization scheduled jobs off and re-run the initial FIM Reporting Synchronization.