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FIM Troubleshooting: SSPR Rich client - "an error was encountered"

PROBLEM STATEMENT

On the Login/Lock Screen (CTRL+ALT+DEL) you click the button or link for Password Reset.  After clicking the link, you receive an error "An error was encountered"

CAUSE:

Name resolution:  Although the Self-Service Password Reset (SSPR) client was configured to use FQDNs the server handed back a NetBIOS name. When the client attempts to use the NetBIOS name the Password Reset fails.

SOLUTION:

Configure the FIM Service to use FQDNs with the clients.

  1. Open a Windows Explorer and navigate to the FIM installation path

    (e.g. C:\Program Files\Microsoft Forefront Identity Manager\2010)

  2. Double click on the Service Folder

  3. Locate and Edit the Microsoft.ResourceManagement.Service.exe.config file.

  4. Search for resourceManagementService

  5. Modify the value for externalHostName to equal the FQDN

    (e.g. 

      <resourceManagementClient resourceManagementServiceBaseAddress="fim01" />

    **  <resourceManagementService externalHostName="fim01.contoso.com" />**)

 

ADDITIONAL INFORMATION: