FIM SSPR Troubleshooting: Could not connect to the password reset service.
Problem Statement
From the CTRL+ALT+DEL screen, an end user attempts to reset their password by clicking on the link. However, the end-user is not registered for password reset so the error message "Could not connect to the password reset service. Wait one minute and try again. If the problem persists, please contact your helpdesk or system administrator." is displayed to the end user.
Testing Self-Service Password Reset Registration once logged in, all works correctly.
https://microsoft.sharepoint.com/teams/iamsupport/iamblog/SiteAssets/BlogSSPR.png
Cause
This was caused by the Forefront Identity Manager Password Reset Client service not being started on the client machine.
Resolution
To resolve the issue, start the Forefront Identity Manager Password Reset Client service. You can do this through one of the following options:
- net start FIMPasswordReset from an Administrative Command-Prompt
- Open the Services MMC and locate and start the service
After starting the Forefront Identity Manager Password Reset Client service, clicking the link resulted in being prompted to authenticate using the QA gate questions. The error indicates that the problem is being unable to connect to the web service but it is actually a failure to connect to the Forefront Identity Manager Password Reset Client service.
See Also
- Self-Service Password Reset (SSPR) Resources Wiki: http://social.technet.microsoft.com/wiki/contents/articles/9846.self-service-password-reset-sspr-resources.aspx